For complete changes, please refer http://dev.mysql.com/doc/refman/5.0/en/releasenotes-cs-5-0-67.html. Here is a part of it. Functionality added or changed: Security Enhancement: To enable stricter control over the location from which user-defined functions can be loaded, the plugin_dir system variable has been backported from MySQL 5.1. If the value is non-empty, user-defined function object files can be loaded only from the directory named by this variable. If the value is empty, the behavior that is used before 5.0.67 applies: The UDF object files must be located in a directory that is searched by your system's dynamic linker. (Bug#37428) Important Change: Incompatible Change: The FEDERATED storage engine is now disabled by default in the .cnf files shipped with MySQL distributions (my-huge.cnf, my-medium.cnf, and so forth). This affects server behavior only if you install one of these files. (Bug#37069) Cluster API: Important Change: Because NDB_LE_MemoryUsage.page_size_kb shows memory page sizes in bytes rather than kilobytes, it has been renamed to page_size_bytes. The name page_size_kb is now deprecated and thus subject to removal in a future release, although it currently remains supported for reasons of backward compatibility. See The Ndb_logevent_type Type, for more information about NDB_LE_MemoryUsage. (Bug#30271) Important Change: Some changes were made to CHECK TABLE ... FOR UPGRADE and REPAIR TABLE with respect to detection and handling of tables with incompatible .frm files (files created with a different version of the MySQL server). These changes also affect mysqlcheck because that program uses CHECK TABLE and REPAIR table, and thus also mysql_upgrade because that program invokes mysqlcheck.
16 lines
697 B
Text
16 lines
697 B
Text
$NetBSD: patch-ac,v 1.7 2008/09/18 11:50:44 taca Exp $
|
|
|
|
--- configure.in.orig 2008-08-04 21:19:07.000000000 +0900
|
|
+++ configure.in
|
|
@@ -2697,9 +2697,9 @@ linked_client_targets="linked_libmysql_s
|
|
|
|
if test "$THREAD_SAFE_CLIENT" = "no"
|
|
then
|
|
- sql_client_dirs="strings regex mysys dbug extra libmysql client"
|
|
+ sql_client_dirs="strings regex libmysql client"
|
|
else
|
|
- sql_client_dirs="strings regex mysys dbug extra libmysql libmysql_r client"
|
|
+ sql_client_dirs="strings regex libmysql libmysql_r client"
|
|
linked_client_targets="$linked_client_targets linked_libmysql_r_sources"
|
|
AC_CONFIG_FILES(libmysql_r/Makefile)
|
|
AC_DEFINE([THREAD_SAFE_CLIENT], [1], [Should be client be thread safe])
|