pkgsrc/databases/mysql5-client/patches/patch-ag
taca 9ae23cc08c Update mysql5-client pacakge to 5.0.67.
For complete changes, please refer
http://dev.mysql.com/doc/refman/5.0/en/releasenotes-cs-5-0-67.html.
Here is a part of it.


Functionality added or changed:

Security Enhancement:

  To enable stricter control over the location from which user-defined
  functions can be loaded, the plugin_dir system variable has been
  backported from MySQL 5.1. If the value is non-empty, user-defined
  function object files can be loaded only from the directory named by this
  variable. If the value is empty, the behavior that is used before 5.0.67
  applies: The UDF object files must be located in a directory that is
  searched by your system's dynamic linker. (Bug#37428)

Important Change: Incompatible Change:

  The FEDERATED storage engine is now disabled by default in the .cnf files
  shipped with MySQL distributions (my-huge.cnf, my-medium.cnf, and so
  forth). This affects server behavior only if you install one of these
  files. (Bug#37069)

Cluster API: Important Change:

  Because NDB_LE_MemoryUsage.page_size_kb shows memory page sizes in bytes
  rather than kilobytes, it has been renamed to page_size_bytes. The name
  page_size_kb is now deprecated and thus subject to removal in a future
  release, although it currently remains supported for reasons of backward
  compatibility. See The Ndb_logevent_type Type, for more information about
  NDB_LE_MemoryUsage. (Bug#30271)

Important Change:

  Some changes were made to CHECK TABLE ... FOR UPGRADE and REPAIR TABLE
  with respect to detection and handling of tables with incompatible .frm
  files (files created with a different version of the MySQL server). These
  changes also affect mysqlcheck because that program uses CHECK TABLE and
  REPAIR table, and thus also mysql_upgrade because that program invokes
  mysqlcheck.
2008-09-18 11:50:44 +00:00

28 lines
877 B
Text

$NetBSD: patch-ag,v 1.4 2008/09/18 11:50:44 taca Exp $
--- strings/Makefile.in.orig 2008-08-04 15:22:30.000000000 +0300
+++ strings/Makefile.in 2008-09-16 12:18:09.000000000 +0300
@@ -622,7 +622,6 @@
if test -f $$p; then \
f=$(am__strip_dir) \
echo " $(pkglibLIBRARIES_INSTALL) '$$p' '$(DESTDIR)$(pkglibdir)/$$f'"; \
- $(pkglibLIBRARIES_INSTALL) "$$p" "$(DESTDIR)$(pkglibdir)/$$f"; \
else :; fi; \
done
@$(POST_INSTALL)
@@ -630,7 +629,6 @@
if test -f $$p; then \
p=$(am__strip_dir) \
echo " $(RANLIB) '$(DESTDIR)$(pkglibdir)/$$p'"; \
- $(RANLIB) "$(DESTDIR)$(pkglibdir)/$$p"; \
else :; fi; \
done
@@ -639,7 +637,6 @@
@list='$(pkglib_LIBRARIES)'; for p in $$list; do \
p=$(am__strip_dir) \
echo " rm -f '$(DESTDIR)$(pkglibdir)/$$p'"; \
- rm -f "$(DESTDIR)$(pkglibdir)/$$p"; \
done
clean-pkglibLIBRARIES: