pkgsrc/inputmethod/Chinput/patches/patch-aa
shell ff169c7c04 Initial import of Chinput-3.0
(PR#17231 by Rui-Xiang Guo <rxg@netbsd.org>)

Chinese input server
---
Chinput is a Chinese input server. It supports XIM(X Input Method)
Protocol and its own protocol for Chinese platform. XIM is the
standard input protocol for DBCS input in X11. All the clients can
use it if they support XIM.  Chinput now use the input engine(IME)
from Unicon, and it can support both GB and Big5 charset.
2002-06-15 09:31:38 +00:00

36 lines
1.3 KiB
Text

$NetBSD: patch-aa,v 1.1.1.1 2002/06/15 09:31:39 shell Exp $
--- src/Makefile.orig Mon Jun 10 21:05:56 2002
+++ src/Makefile
@@ -1,20 +1,16 @@
-CC = gcc
# do you have imlib?
#No, I don't have that strange library
#IMLIB =
#LIBIMLIB =
-#Yes I have
-IMLIB = -DIMLIB
-LIBIMLIB = -lImlib
#CFLAGS = -Wall -g -DFOR_PILOT_COMPAT -O2 -fno-strength-reduce -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE=500L -D_BSD_SOURCE -D_SVID_SOURCE -DFUNCPROTO=15 -DNARROWPROTO
-CFLAGS = -Wall -g -DFOR_PILOT_COMPAT -O2 -fno-strength-reduce
+CFLAGS += -Wall -DFOR_PILOT_COMPAT -O2 -fno-strength-reduce
INC = -I./include -I./IMdkit/include -I/usr/include -I/usr/X11R6/include
-LIB = -L/usr/X11R6/lib -lXext -lX11 ./IMdkit/lib/libXimd.a -L/usr/lib/unicon2 -limmclient -Wl,-rpath=/usr/lib/unicon2 -limm_server -lpth -ldl
+LIB = -lXext -lX11 ./IMdkit/lib/libXimd.a -limmclient -limm_server -lpth
SRC = chinput.c init.c server.c config.c color.c util.c convert.c IC.c XIM.c focus.c root.c overspot.c onspot.c offspot.c voice.c keyboard.c handw.c hwengine.c loop.c
@@ -23,7 +19,7 @@
all: chinput
chinput: IMdkit/lib/libXimd.a $(OBJ)
- g++ -o chinput $(OBJ) $(LIB) $(LIBIMLIB)
+ $(CC) -o chinput $(OBJ) $(LDFLAGS) $(LIB) $(LIBIMLIB)
.c.o:
$(CC) -c $(CFLAGS) $(IMLIB) $(INC) $<