The PPP Daemon is the userland part of the Point-to-Point Protocol. It works in combination with a dedicated kernel network interface usually named ppp. PPP is a very extensible protocol and pppd supports a large number of options, including compression (through various algorithms), cryptography (Microsoft's MPPE) and authentication (PAP, CHAP, Microsoft CHAP), provided the kernel has the relevant back-ends in some cases.
71 lines
1.7 KiB
Text
71 lines
1.7 KiB
Text
$NetBSD: patch-ah,v 1.1.1.1 2005/01/02 02:51:42 cube Exp $
|
|
|
|
--- netbsd/Makefile.top.orig 2004-12-31 23:50:59.000000000 +0100
|
|
+++ netbsd/Makefile.top
|
|
@@ -0,0 +1,66 @@
|
|
+# PPP top-level Makefile for Linux.
|
|
+
|
|
+DESTDIR = @DESTDIR@
|
|
+BINDIR = $(DESTDIR)/sbin
|
|
+INCDIR = $(DESTDIR)/include
|
|
+MANDIR = $(DESTDIR)/man
|
|
+ETCDIR = @SYSCONF@
|
|
+
|
|
+# uid 0 = root
|
|
+INSTALL= install
|
|
+
|
|
+all:
|
|
+ cd chat; $(MAKE) $(MFLAGS) all
|
|
+# cd pppd/plugins; $(MAKE) $(MFLAGS) all
|
|
+ cd pppd; $(MAKE) $(MFLAGS) all
|
|
+ cd pppstats; $(MAKE) $(MFLAGS) all
|
|
+ cd pppdump; $(MAKE) $(MFLAGS) all
|
|
+
|
|
+install: $(BINDIR) $(MANDIR)/man8 install-progs install-devel
|
|
+
|
|
+install-progs:
|
|
+ cd chat; $(MAKE) $(MFLAGS) install
|
|
+# cd pppd/plugins; $(MAKE) $(MFLAGS) install
|
|
+ cd pppd; $(MAKE) $(MFLAGS) install
|
|
+ cd pppstats; $(MAKE) $(MFLAGS) install
|
|
+ cd pppdump; $(MAKE) $(MFLAGS) install
|
|
+
|
|
+install-etcppp: $(ETCDIR) $(ETCDIR)/options $(ETCDIR)/pap-secrets \
|
|
+ $(ETCDIR)/chap-secrets
|
|
+
|
|
+install-devel:
|
|
+ cd pppd; $(MAKE) $(MFLAGS) install-devel
|
|
+
|
|
+$(ETCDIR)/options:
|
|
+ $(INSTALL) -c -m 644 etc.ppp/options $@
|
|
+$(ETCDIR)/pap-secrets:
|
|
+ $(INSTALL) -c -m 600 etc.ppp/pap-secrets $@
|
|
+$(ETCDIR)/chap-secrets:
|
|
+ $(INSTALL) -c -m 600 etc.ppp/chap-secrets $@
|
|
+
|
|
+$(BINDIR):
|
|
+ $(INSTALL) -d -m 755 $@
|
|
+$(MANDIR)/man8:
|
|
+ $(INSTALL) -d -m 755 $@
|
|
+$(ETCDIR):
|
|
+ $(INSTALL) -d -m 755 $@
|
|
+
|
|
+clean:
|
|
+ rm -f `find . -name '*.[oas]' -print`
|
|
+ rm -f `find . -name 'core' -print`
|
|
+ rm -f `find . -name '*~' -print`
|
|
+ cd chat; $(MAKE) clean
|
|
+# cd pppd/plugins; $(MAKE) clean
|
|
+ cd pppd; $(MAKE) clean
|
|
+ cd pppstats; $(MAKE) clean
|
|
+ cd pppdump; $(MAKE) clean
|
|
+
|
|
+dist-clean: clean
|
|
+ rm -f Makefile `find . -name Makefile -print`
|
|
+
|
|
+#kernel:
|
|
+# cd linux; ./kinstall.sh
|
|
+
|
|
+# no tests yet, one day...
|
|
+installcheck:
|
|
+ true
|