ea01694e1e
11 Jun 2015, PHP 5.6.10 - Core: . Fixed bug #66048 (temp. directory is cached during multiple requests). (Julien) . Fixed bug #69566 (Conditional jump or move depends on uninitialised value in extension trait). (jbboehr at gmail dot com) . Fixed bug #69599 (Strange generator+exception+variadic crash). (Nikita) . Fixed bug #69628 (complex GLOB_BRACE fails on Windows). (Christoph M. Becker) . Fixed POST data processing slowdown due to small input buffer size on Windows. (Jorge Oliveira, Anatol) . Fixed bug #69646 (OS command injection vulnerability in escapeshellarg). (Anatol Belski) . Fixed bug #69719 (Incorrect handling of paths with NULs). (Stas) - FTP . Improved fix for bug #69545 (Integer overflow in ftp_genlist() resulting in heap overflow). (Max Spelsberg) - GD: . Fixed bug #69479 (GD fails to build with newer libvpx). (Remi) - Iconv: . Fixed bug #48147 (iconv with //IGNORE cuts the string). (Stas) - Litespeed SAPI: . Fixed bug #68812 (Unchecked return value). (George Wang) - Mail: . Fixed bug #68776 (mail() does not have mail header injection prevention for additional headers). (Yasuo) - MCrypt: . Added file descriptor caching to mcrypt_create_iv() (Leigh) - Opcache . Fixed bug #69549 (Memory leak with opcache.optimization_level=0xFFFFFFFF). (Laruence, Dmitry) - Phar: . Fixed bug #69680 (phar symlink in binary directory broken). (Matteo Bernardini, Remi) - Postgres: . Fixed bug #69667 (segfault in php_pgsql_meta_data). (Remi) - Sqlite3: . Upgrade bundled sqlite to 3.8.10.2. (CVE-2015-3414, CVE-2015-3415, CVE-2015-3416) (Kaplan)
13 lines
662 B
JavaScript
13 lines
662 B
JavaScript
$NetBSD: patch-ext_phar_Makefile.frag,v 1.3 2015/06/12 00:47:03 taca Exp $
|
|
|
|
--- ext/phar/Makefile.frag.orig 2015-06-10 07:42:27.000000000 +0000
|
|
+++ ext/phar/Makefile.frag
|
|
@@ -18,7 +18,7 @@ PHP_PHARCMD_EXECUTABLE = ` \
|
|
else \
|
|
$(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
|
|
fi;`
|
|
-PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
+PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
|
|
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
|
|
-@test -d $(builddir)/phar || mkdir $(builddir)/phar
|