pkgsrc/lang/sr/patches/patch-at
is 546b2b16f7 Make this actually link for non-i386, as intended.
Problem reported by Klaus J. Klein, Method suggested bei Nick Hudson.
2005-03-01 12:55:01 +00:00

36 lines
938 B
Text

$NetBSD: patch-at,v 1.2 2005/03/01 12:55:01 is Exp $
--- csw/Makefile.orig 1999-07-30 05:01:50.000000000 +0000
+++ csw/Makefile
@@ -1,6 +1,6 @@
## Makefile for the SR context switch routines.
-CFLAGS = -g
+CFLAGS = -O3
SHELL = /bin/sh
SRC = alpha.s ap3000.s bobcat.s encore.s i386.s m68k.s m88k.s mips.s \
@@ -27,19 +27,15 @@ cstest: cstest.o asm.o
# csloop is a timing program, built only on request
csloop: csloop.o asm.o
- . ../paths.sh; $(CC) -O -o csloop csloop.o asm.o $$LIBR $$LIBC
+ . ../paths.sh; $(CC) -g -o csloop csloop.o asm.o $$LIBR $$LIBC
csloop.o: csloop.c
$(CC) -O -c csloop.c
-# asm.o holds the actual context switch code
-
-asm.o: asm.c ../arch.h $(SRC)
- $(CC) $(CFLAGS) -E asm.c | \
- sed -e '/^ *$$/d' -e '/^#/'d -e 's/ :/:/' >asm.s
- as -o asm.o asm.s
-
+asm.o: netbsd.c
+ $(CC) $(CFLAGS) -c netbsd.c
+ $(LD) -r -o asm.o netbsd.o /usr/lib/libpthread.a
# miscellaneous utility targets