e38d9d3ce7
2004-05-16 Sam Clegg * Version 0.5.7 * Implement simple config dialog. * When fast playtime calculation is enabled, dedode the first 10 frames only. 2004-01-24 Sam Clegg * decoder.c: better xing bitrate calculation. 2003-12-28 Sam Clegg * Version 0.5.6 * configure.ac: don't depend on pkgconfig files from libmad and libid3tag that aren't shipped by upstream * decoder.c xmms-mad.[ch]: fix xing header usage. added use_xing configuration option to disable it.
23 lines
503 B
Text
23 lines
503 B
Text
$NetBSD: patch-aa,v 1.4 2006/08/07 23:46:23 wiz Exp $
|
|
|
|
--- src/decoder.c.orig 2004-05-16 17:08:05.000000000 +0000
|
|
+++ src/decoder.c
|
|
@@ -274,6 +274,9 @@ decode (void *arg)
|
|
/* main loop */
|
|
do
|
|
{
|
|
+#ifdef _PTH_PTHREAD_H_
|
|
+ sched_yield();
|
|
+#endif
|
|
if (info->stop)
|
|
break;
|
|
if (seek_skip)
|
|
@@ -430,6 +433,8 @@ decode (void *arg)
|
|
#endif /* DEBUG */
|
|
|
|
mad_plugin.output->close_audio ();
|
|
+ close (info->infile);
|
|
+ info->infile = 0;
|
|
info->stop = 1;
|
|
pthread_exit (0);
|
|
}
|