52164ce712
Also, stop the package from compressing the man pages. From Geert Hendrickx in private mail.
29 lines
1.4 KiB
Text
29 lines
1.4 KiB
Text
$NetBSD: patch-ac,v 1.2 2005/12/08 01:04:45 wiz Exp $
|
|
|
|
--- src/console/Makefile.in.orig 2004-06-20 15:43:02.000000000 +0400
|
|
+++ src/console/Makefile.in
|
|
@@ -82,19 +82,19 @@ install: all
|
|
fi
|
|
$(INSTALL_PROGRAM) bconsole $(DESTDIR)$(sbindir)/bconsole
|
|
@srcconf=bconsole.conf; \
|
|
- if test -f ${DESTDIR}${sysconfdir}/$$srcconf; then \
|
|
+ if test -f ${DESTDIR}%%EXAMPLESDIR%%/$$srcconf; then \
|
|
destconf=$$srcconf.new; \
|
|
echo " ==> Found existing $$srcconf, installing new conf file as $$destconf"; \
|
|
else \
|
|
destconf=$$srcconf; \
|
|
- if test -f ${DESTDIR}${sysconfdir}/console.conf; then \
|
|
+ if test -f ${DESTDIR}%%EXAMPLESDIR%%/console.conf; then \
|
|
echo "Existing console.conf moved to bconsole.conf"; \
|
|
- @$(MV) ${DESTDIR}${sysconfdir}/console.conf ${DESTDIR}${sysconfdir}/bconsole.conf; \
|
|
+ @$(MV) ${DESTDIR}%%EXAMPLESDIR%%/console.conf ${DESTDIR}%%EXAMPLESDIR%%/bconsole.conf; \
|
|
destconf=$$srcconf.new; \
|
|
fi; \
|
|
fi; \
|
|
- echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf"; \
|
|
- ${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf
|
|
+ echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}%%EXAMPLESDIR%%/$$destconf"; \
|
|
+ ${INSTALL_CONFIG} $$srcconf ${DESTDIR}%%EXAMPLESDIR%%/$$destconf
|
|
if test -f static-bconsole; then \
|
|
$(INSTALL_PROGRAM) static-bconsole $(DESTDIR)$(sbindir)/static-bconsole; \
|
|
fi
|