pkgsrc/wm/wm2/patches/patch-aa
jlam 63fc151cb9 Use x11.buildlink.mk instead of USE_X11. Also convert hard-coded references
to ${X11BASE} in the header and library search paths into references to
${LOCALBASE}/share/x11-links.  These packages should now be strongly-
buildlinked regardless of whether xpkgwedge is installed.

Changes well-tested on NetBSD-1.5X/i386 with and without xpkgwedge and
lightly-tested on NetBSD-1.5.1/alpha without xpkgwedge.
2001-08-29 22:41:00 +00:00

27 lines
568 B
Text

$NetBSD: patch-aa,v 1.2 2001/08/29 22:41:26 jlam Exp $
--- Makefile.orig Fri Mar 21 06:12:30 1997
+++ Makefile
@@ -1,9 +1,9 @@
-LIBS = -L/usr/X11/lib -lXext -lX11 -lXmu -lm
+LIBS = ${LDFLAGS} -lXext -lX11 -lXmu -lm
-CC = gcc
-CCC = gcc
-CFLAGS = -O2
+#CC = gcc
+#CCC = gcc
+#CFLAGS = -O2
OBJECTS = Border.o Buttons.o Client.o Events.o Main.o Manager.o Rotated.o
.c.o:
@@ -13,7 +13,7 @@
$(CCC) -c $(CFLAGS) $<
wm2: $(OBJECTS)
- mv -f wm2 wm2.old >& /dev/null || true
+ mv -f wm2 wm2.old 2> /dev/null || true
$(CCC) -o wm2 $(OBJECTS) $(LIBS)
depend: