743455bdb1
(issue in ucd-snmp side - submitted diff to ucd-snmp-coders@ucdavis) depend on devel/autoconf, to simplify the build. ELF breakage reported from: "Michael L. Hitch" <mhitch@lightning.msu.montana.edu>
112 lines
2.4 KiB
Text
112 lines
2.4 KiB
Text
$NetBSD: patch-aa,v 1.10 2000/01/24 04:18:37 itojun Exp $
|
|
--- configure.in.orig Fri Jan 21 07:52:17 2000
|
|
+++ configure.in Fri Jan 21 08:04:52 2000
|
|
@@ -407,7 +407,8 @@
|
|
else
|
|
SHLIB_CFLAGS="-Kpic"
|
|
fi
|
|
- SHLIB_EXTENSION="so"
|
|
+# SHLIB_EXTENSION="so"
|
|
+ SHLIB_EXTENSION="la"
|
|
SHLIB_VERSION=
|
|
SHLIB_LD_CMD="ld -r -o"
|
|
SHLIB_LDCONFIG_CMD=
|
|
@@ -712,7 +713,7 @@
|
|
done
|
|
module_list_o=`echo "$module_list_code " | sed 's/\([^ ]\) /\1.o /g'`
|
|
module_list_c=`echo "$module_list_code " | sed 's/\([^ ]\) /\1.c /g'`
|
|
-mibgroup_list_o=`echo " $module_list_o " | sed 's@ \([^ ]*\)\.o@ mibgroup/\1.o @g'`
|
|
+mibgroup_list_o=`echo " $module_list_o " | sed -e 's@ \([^ ]*\)\.o@ mibgroup/\1.o @g' -e 's@ mibgroup/[^ ]*/\([^ /]*\).o@ mibgroup/\1.o@g'`
|
|
changequote([, ])
|
|
AC_SUBST(module_list_c)
|
|
AC_SUBST(module_list_h)
|
|
@@ -1034,11 +1035,7 @@
|
|
|
|
AC_CHECK_STRUCT_FOR([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
], rtentry, rt_dst, no)
|
|
|
|
@@ -1049,11 +1046,7 @@
|
|
dnl 4.4 compat
|
|
AC_TRY_COMPILE([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
],[
|
|
|
|
@@ -1070,11 +1063,7 @@
|
|
if test "x$ac_cv_RTENTRY_TYPE" = "x"; then
|
|
AC_TRY_COMPILE([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
],[
|
|
struct rtentry rt;
|
|
@@ -1124,11 +1113,7 @@
|
|
[
|
|
AC_TRY_COMPILE([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
],[
|
|
struct rtentry rt;
|
|
@@ -1145,41 +1130,25 @@
|
|
dnl Check struct rtentry for various things.
|
|
AC_CHECK_STRUCT_FOR([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
], rtentry, rt_unit)
|
|
|
|
AC_CHECK_STRUCT_FOR([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
], rtentry, rt_refcnt)
|
|
|
|
AC_CHECK_STRUCT_FOR([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
], rtentry, rt_hash)
|
|
|
|
AC_CHECK_STRUCT_FOR([
|
|
#include <sys/types.h>
|
|
-#define KERNEL
|
|
-#define _KERNEL
|
|
#include <sys/socket.h>
|
|
-#undef KERNEL
|
|
-#undef _KERNEL
|
|
#include <net/route.h>
|
|
], rtentry, rt_use)
|
|
|