Alan Coopersmith (20): Move Compose \ o / to be with other emoji compose sequences Replace Xmalloc+memset pairs with Xcalloc calls Get rid of some extraneous ; at the end of C source lines Remove unused definition of XCONN_CHECK_FREQ Bug 93184: read_EncodingInfo invalid free Bug 93183: _XDefaultOpenIM memory leaks in out-of-memory error paths Delete #if 0 hunks of code Use strdup instead of Xmalloc+strcpy in _XDefaultOpenIM XDefaultOMIF: replace strlen+Xmalloc+strcpy with strdup XDefaultOMIF: additional code simplification XDefaultOMIF: Remove comments referring to ancient Sun bug ids XlcDL.c: replace strcpy+strcat sequences with snprintf XlcDL.c: reduce code duplication lcPubWrap: replace malloc(strlen) + strcpy with strdup Stop checking XTRANS_SECURE_RPC_FLAGS since we no longer use them Stop checking for preferred order of local transports Don't need to link libX11-xcb against libX11 xcms: use size_t for strlen/sizeof values instead of converting to int & back xcms: use unsigned indexes when looping through unsigned values xcms: use size_t for pointer offsets passed to strncmp Bhavi Dhingra (1): omGeneric.c: Correct the parameter usage of sizeof Christian Linhart (1): fix for Xlib 32-bit request number issues Daniel Albers (1): Add Compose sequence for U+1F4A9. Dominik Muth (1): Xlib.h: Fix macros imitating C functions. Gunnar Hjalmarsson (1): Add compose file for pt_PT similar to pt_BR James Cloos (2): Fix missing update in cf4d5989383a Fix another missing update in cf4d5989383a Julien Cristau (1): Mark _XNextRequest as hidden Mats Blakstad (1): New compose keys for local languages in Togo Matthew D. Fuller (1): Fixup param specification for XChangeProperty() Matthieu Herrb (1): libX11 1.6.4 Mike FABIAN (3): add be_BY.UTF-8@latin and sr_RS.UTF-8@latin to locale.dir fix spelling mistakes in ks_IN and sd_IN devanagari locales Fix spelling mistake introduced by 748d47e69f5c12d8557d56a8a8ec166588da7b93 Olivier Fourdan (1): XKB: fix XkbGetKeyboardByName with Xming server Peter Hutterer (3): Fix potential memory leak Fix an indentation issue Fix three "use of uninitialized variable" coverity warnings Ross Burton (1): Add missing NULL checks to ICWrap Thomas Klausner (2): Do not return() after exit(). Ignore test-driver (used by newer autoconf). Tobias Stoeckmann (2): The validation of server responses avoids out of boundary accesses. Validation of server responses in XGetImage() walter harms (1): XFree will accept NULL as argument
16 lines
702 B
Text
16 lines
702 B
Text
$NetBSD: patch-Makefile.in,v 1.4 2016/10/04 21:58:10 wiz Exp $
|
|
|
|
Avoid unnecessary auto* due to patch-aa modifying configure.ac.
|
|
|
|
--- Makefile.in.orig 2016-10-04 19:03:39.000000000 +0000
|
|
+++ Makefile.in
|
|
@@ -90,8 +90,7 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/a
|
|
$(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/ltoptions.m4 \
|
|
$(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
|
|
$(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/configure.ac
|
|
-am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
|
|
- $(ACLOCAL_M4)
|
|
+am__configure_deps =
|
|
am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
|
|
configure.lineno config.status.lineno
|
|
mkinstalldirs = $(install_sh) -d
|