pkgsrc/devel/py-Checker-mixedcase/patches/patch-aa
shell 21b8344511 Updated py-Checker to 0.8.10 .
Changes for 0.8.9 to 0.8.10 :
  * Add --unpack option to warn when unpacking a non-sequence
  * Add --unpacklen option to warn when unpacking sequence of wrong size
  * Add --changetypes option to warn when setting a variable to different types
  * Add --stringiter option to warn when iterating over a string
  * Add --input option to warn when using input()
  * Fix crash with checking properties or deriving from objects (2.2 only)
  * Fix crash with nested scopes and lambdas
  * Fix spurious warnings for constant conditionals when using ('%s' % value)
  * Fix spurious warnings for unused identifiers caused by from XXX import *
  * Add more information when module cannot be imported
  * Fix spurious warnings for implicit returns when using while 1:
  * Fix spurious warnings for implicit returns when using try/finally:
  * Fix spurious warning with globals that start w/__
  * Fix spurious warnings for modifying default arguments
        when calling {}.get(), {}.has_key(), [].index(), [].count(), etc.
  * Fix spurious warnings in Python 1.5.2 when using from/import

(Please see CHANGELOG for more)
2002-06-10 02:25:03 +00:00

33 lines
1.1 KiB
Text

$NetBSD: patch-aa,v 1.2 2002/06/10 02:25:03 shell Exp $
--- setup.py.orig Thu Mar 21 03:13:13 2002
+++ setup.py Fri Apr 19 18:25:05 2002
@@ -10,7 +10,7 @@
import sys
import os
-import tempfile
+#import tempfile
from distutils.core import setup
from distutils import sysconfig
@@ -41,8 +41,8 @@
script_str = '%s %s %%*\n' % (py_exe, checker_py)
script_suffix = '.bat'
- LOCAL_SCRIPT = 'pychecker' + script_suffix
- LOCAL_SCRIPT = os.path.join(tempfile.gettempdir(), LOCAL_SCRIPT)
+ LOCAL_SCRIPT = 'pyChecker' + script_suffix
+ LOCAL_SCRIPT = os.path.join('./', LOCAL_SCRIPT)
remove_file(LOCAL_SCRIPT)
try :
@@ -63,7 +63,7 @@
author_email = "pychecker@metaslash.com",
url = "http://pychecker.sourceforge.net/",
packages = [ 'pychecker' ],
- data_files = [ (install_dir, DOC_FILES) ],
+# data_files = [ (install_dir, DOC_FILES) ],
scripts = [ LOCAL_SCRIPT, ],
long_description = LONG_DESCRIPTION
)