f8a051df2d
diffferent bsd.prog.mks, which doesn't matter for pkgsrc.
35 lines
941 B
Text
35 lines
941 B
Text
$NetBSD: patch-ab,v 1.1 2006/02/24 20:17:55 joerg Exp $
|
|
|
|
--- Makefile.orig 2006-02-24 20:08:55.000000000 +0000
|
|
+++ Makefile
|
|
@@ -84,17 +84,8 @@ SRCS= mld6.c mld6_proto.c\
|
|
inet6.c kern.c main.c config.c debug.c routesock.c vers.c callout.c\
|
|
route.c vif.c timer.c mrt.c pim6.c pim6_proto.c trace.c
|
|
|
|
-.if (${OPSYS} == "BSD/OS")
|
|
-CC= gcc
|
|
-.endif
|
|
-.if (${OPSYS} != "NetBSD")
|
|
-CFLAGS+=-Wall
|
|
-.endif
|
|
-.if (${OPSYS} != "NetBSD")
|
|
-CFLAGS+=-DINET6 -DPIM -DIOCTL_OK_ON_RAW_SOCKET
|
|
-.else
|
|
CPPFLAGS+=-DINET6 -DPIM -DIOCTL_OK_ON_RAW_SOCKET
|
|
-.endif
|
|
+
|
|
.if exists(/usr/local/v6/lib/libinet6.a)
|
|
LDADD+= -L${.OBJDIR}/../libinet6 -L${.OBJDIR}/../libinet6/obj \
|
|
-L/usr/local/v6/lib -linet6
|
|
@@ -103,11 +94,6 @@ DPADD+= ${.OBJDIR}/../libinet6/libinet6.
|
|
/usr/local/v6/lib/libinet6.a
|
|
.endif
|
|
|
|
-.if (${OPSYS} == "NetBSD") || (${OPSYS} == "OpenBSD")
|
|
MAN= pim6dd.8 pim6dd.conf.5
|
|
-.else
|
|
-MAN5= pim6dd.conf.5
|
|
-MAN8= pim6dd.8
|
|
-.endif
|
|
|
|
.include <bsd.prog.mk>
|