35dfda410c
Dragonfly users, please test that is still builds ! pkgsrc change: as snmp support doesn't depend on net-snmp anymore, remove snmp option and always build snmp support. cgi option now depend on graphics/gd/ User-visible changes sinces 3.14.3: 2010-08-30 14:18 adk0212 * src/drivers/snmplite/: mge-mib.cpp, mge-oids.h, mibs.cpp: Add support for MGE SNMP MIB. Contributed by Lars Täer <taeuber@bbaw.de> 2010-07-30 18:04 adk0212 * src/drivers/snmplite/: apc-mib.cpp, apc-oids.h, mib.cpp, oids.h, rfc1628-mib.cpp, rfc1628-oids.h, snmplite.cpp, snmplite.h: Add support for RFC1628 SNMP MIB. Refactor APC MIB and create MibStrategy struct for associating MIB/CI mapping with corresponding processing function. RFC1628 strategy is coded per the MIB but untested. 2010-01-10 10:29 adk0212 * include/defines.h, src/apctest.c, src/drivers/usb/usb.c: Add apctest support for reading/setting self-test interval on USB. Also show current setting in UPS status. Contributed by James Belleau <jpbelleau@gmail.com> 2009-10-25 11:03 adk0212 * configure, autoconf/config.h.in, autoconf/configure.in, autoconf/variables.mak.in, include/struct.h, platforms/etc/apcupsd.conf.in, src/drivers/Makefile, src/drivers/drivers.c, src/drivers/snmplite/Makefile, src/drivers/snmplite/asn.cpp, src/drivers/snmplite/asn.h, src/drivers/snmplite/mib.cpp, src/drivers/snmplite/snmp.cpp, src/drivers/snmplite/snmp.h, src/drivers/snmplite/snmplite.cpp, src/drivers/snmplite/snmplite.h, src/lib/apcconfig.c, src/lib/apcstatus.c: Add SNMP Lite driver which does not depend on net-snmp library. This makes it more portable and eliminates need to move libsnmp.so to /lib in order to do a killpower on systems where /usr is unmounted. 2009-09-01 20:30 adk0212 * src/apctest.c: Implement battery calibration in apctest for USB models. Thanks to James Belleau <james@belleau.net> for the original implementation which has been modified somewhat in this commit. 2009-05-02 10:30 adk0212 * src/action.c: Change log level of UPS self-test messages to WARNING from ALERT. Given that self-test messages are routine, they do not belong at LOG_ALERT. Contributed by Dave Ewart <davee@ceu.ox.ac.uk>. 2009-04-25 10:58 adk0212 * src/lib/apcconfig.c: Remove EVENTFILE, EVENTFILEMAX config directives. These were replaced by the plural versions that are in use today (EVENTSFILE, EVENTSFILEMAX) almost 10 years ago. It's time to kill the old names. (h/t Trevor Roydhouse <trev@sentry.org>) 2009-03-02 17:48 adk0212 * doc/apcupsd.man, include/drivers.h, include/extern.h, src/action.c, src/apctest.c, src/apcupsd.c, src/device.c, src/options.c, src/drivers/drivers.c, src/drivers/apcsmart/apcsmart.h, src/drivers/apcsmart/smart.c, src/drivers/apcsmart/smartoper.c, src/drivers/usb/usb.c, src/drivers/usb/usb.h, src/lib/apclock.c: Add support for turning the UPS off completely. This complements existing hibernate (aka killpower) functionality. Turn-off is implemented for apcsmart and USB drivers, subject to support for the relevant commands in the UPS itself. Contributed by Keith Campbell <campbell@econnectix.com>. 2008-06-29 11:12 adk0212 * src/action.c: Fix bug in LOWBATT glitch handling. We must examine LOWBATT for changes every time thru the status loop, not just during the OnBattery state. Otherwise we can miss the initial LOWBATT assertion, which defeats the glitch rejection logic. 2008-05-06 20:16 skoona * src/gapcmon/gapcmon.c: Corrected the use of NOMPOWER and the calc of current usage amount 2008-05-04 11:13 adk0212 * src/drivers/usb/usb.c: Add a heuristic to fix up incorrect NOMINV or NOMOUTV. Some UPSes (RS 500) report decivolts instead of volts. Reported by Kirill S. Bychkov <yason@linklevel.net>. 2008-01-27 12:00 adk0212 * include/struct.h, platforms/etc/apcupsd.conf.in, platforms/mingw/apcupsd.conf.in, src/device.c, src/drivers/net/net.c, src/drivers/snmp/drv_powernet.c, src/lib/apcconfig.c: Add POLLTIME directive to control UPS polling interval. NETTIME is accepted as a synonym for compatibility with old config files.
19 lines
742 B
Text
19 lines
742 B
Text
$NetBSD: patch-ao,v 1.7 2011/08/01 14:54:51 bouyer Exp $
|
|
|
|
--- platforms/Makefile.orig 2011-08-01 15:55:53.000000000 +0200
|
|
+++ platforms/Makefile 2011-08-01 15:56:26.000000000 +0200
|
|
@@ -9,14 +9,6 @@
|
|
all-uninstall: uninstall-platform
|
|
|
|
install-platform:
|
|
- $(call MKDIR,$(sysconfdir))
|
|
- $(if $(wildcard ./$(DISTNAME)/apccontrol), \
|
|
- $(call INSTORIG,744,$(DISTNAME)/apccontrol,$(sysconfdir)), \
|
|
- $(call INSTORIG,744,apccontrol,$(sysconfdir)))
|
|
- $(if $(HALPOLICYDIR),$(call MKDIR,$(HALPOLICYDIR)))
|
|
- $(if $(HALPOLICYDIR),$(call INSTDATA,644,80-apcupsd-ups-policy.fdi,$(HALPOLICYDIR)))
|
|
|
|
uninstall-platform:
|
|
- $(call UNINST,$(sysconfdir)/apccontrol)
|
|
- $(if $(HALPOLICYDIR),$(call UNINST,$(HALPOLICYDIR)/80-apcupsd-ups-policy.fdi))
|
|
|