c5075fd437
(change to register distutils egg-info) Version 7.19.0 [requires libcurl-7.19.0 or better] -------------- * Added CURLFILE, ADDRESS_SCOPE and ISSUERCERT options, as well as the APPCONNECT_TIME info. * Added PRIMARY_IP info (patch by Yuhui H <eyecat at gmail.com>). * Added support for curl_easy_reset through a new 'reset' method on curl objects (patch by Nick Pilon <npilon at oreilly.com>). * Added support for OPENSOCKET callbacks. See 'tests/test_opensocket.py' for example usage (patch by Thomas Hunger <teh at camvine.com>). Version 7.18.2 -------------- * Added REDIRECT_URL info and M_MAXCONNECTS option (patch by Yuhui H <eyecat at gmail.com>). * Added socket_action() method to CurlMulti objects. See 'tests/test_multi_socket_select.py' for example usage (patch by Yuhui H <eyecat at gmail.com>). * Added AUTOREFERER option. * Allow resetting some list operations (HTTPHEADER, QUOTE, POSTQUOTE, PREQUOTE) by passing an empty list to setopt (patch by Jim Patterson). Version 7.18.1 -------------- * Added POST301, SSH_HOST_PUBLIC_KEY_MD5, COPYPOSTFIELDS and PROXY_TRANSFER_MODE options. * Check for static libs in setup.py to better detect whether libcurl was linked with OpenSSL or GNUTLS. * PycURL is now dual licensed under the LGPL and a license similar to the cURL license (an MIT/X derivative).
16 lines
656 B
Text
16 lines
656 B
Text
$NetBSD: patch-aa,v 1.7 2012/01/25 13:19:57 obache Exp $
|
|
|
|
--- setup.py.orig 2008-09-09 17:40:34.000000000 +0000
|
|
+++ setup.py
|
|
@@ -149,9 +149,9 @@ def get_data_files():
|
|
# a list of tuples with (path to install to, a list of local files)
|
|
data_files = []
|
|
if sys.platform == "win32":
|
|
- datadir = os.path.join("doc", PACKAGE)
|
|
+ datadir = os.path.join("doc", PACKAGE + sys.version[0:3])
|
|
else:
|
|
- datadir = os.path.join("share", "doc", PACKAGE)
|
|
+ datadir = os.path.join("share", "doc", PACKAGE + sys.version[0:3])
|
|
#
|
|
files = ["ChangeLog", "COPYING", "COPYING2", "INSTALL", "README", "TODO",]
|
|
if files:
|