Only print script warnings when a script is used. Remove stray mention of script-security system. Move settings of user script into set_user_script function Move checking of script file access into set_user_script Provide more accurate warning message Fix NULL-pointer crash in route_list_add_vpn_gateway(). Fix problem with UDP tunneling due to mishandled pktinfo structures. Always push basic set of peer info values to server. make 'explicit-exit-notify' pullable again Fix proto tcp6 for server & non-P2MP modes Fix Windows script execution when called from script hooks Fixed tls-cipher translation bug in openssl-build Fixed usage of stale define USE_SSL to ENABLE_SSL Fix segfault when enabling pf plug-ins
35 lines
897 B
Text
35 lines
897 B
Text
$NetBSD: patch-ae,v 1.7 2013/07/31 06:53:21 adam Exp $
|
|
|
|
--- configure.ac.orig 2013-05-31 12:00:25.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -419,6 +419,7 @@ AC_CHECK_HEADERS([ \
|
|
sys/mman.h sys/file.h sys/wait.h \
|
|
unistd.h signal.h libgen.h stropts.h \
|
|
syslog.h pwd.h grp.h \
|
|
+ net/if_tap.h \
|
|
sys/sockio.h sys/uio.h linux/sockios.h \
|
|
linux/types.h sys/poll.h sys/epoll.h err.h \
|
|
])
|
|
@@ -433,6 +434,9 @@ SOCKET_INCLUDES="
|
|
#ifdef HAVE_SYS_SOCKET_H
|
|
#include <sys/socket.h>
|
|
#endif
|
|
+#ifdef HAVE_NET_IF_H
|
|
+#include <net/if.h>
|
|
+#endif
|
|
#ifdef HAVE_NETINET_IN_H
|
|
#include <netinet/in.h>
|
|
#endif
|
|
@@ -496,6 +500,12 @@ AC_CHECK_TYPE(
|
|
,
|
|
[[${SOCKET_INCLUDES}]]
|
|
)
|
|
+AC_CHECK_MEMBER(
|
|
+ [struct in_pktinfo.ipi_spec_dst],
|
|
+ [AC_DEFINE([HAVE_IPI_SPEC_DST], [1], [struct in_pktinfo.ipi_spec_dst needed for IP_PKTINFO support])],
|
|
+ ,
|
|
+ [[${SOCKET_INCLUDES}]]
|
|
+)
|
|
AC_CHECK_TYPE(
|
|
[struct sockaddr_in6],
|
|
,
|