pkgsrc/net/netatalk22/patches/patch-config_Makefile.in
hauke f1be08fe1f Update netatalk22 to patch release 2.2.6.
For changes see
<https://github.com/Netatalk/Netatalk/commits/branch-netatalk-2-2>
- the upstream release branch does not have a changelog.

Upstream took a lot of our patches - thanks, guys!

Package changes include untangling ldap support, so that the package
builds with it. There has been confusion between acl and ldap support
upstream as well as in the package - see
patch-include_atalk_ldapconfig.h and
<https://github.com/Netatalk/Netatalk/commits/branch-netatalk-2-2/include/atalk/ldapconfig.h>.
2017-07-12 13:56:00 +00:00

28 lines
1.1 KiB
Text

$NetBSD: patch-config_Makefile.in,v 1.1 2017/07/12 13:56:00 hauke Exp $
Install config files to examples/netatalk, and leave installation to
the pkginstall framerwork.
Renamed from patch-ah
--- config/Makefile.in.orig 2011-09-06 07:41:20.000000000 -0400
+++ config/Makefile.in 2011-09-21 09:34:21.000000000 -0400
@@ -614,13 +614,14 @@
rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
done
@USE_DEBIAN_TRUE@ rm -f $(DESTDIR)/etc/default/netatalk
+egconfdir = @prefix@/share/examples/netatalk
install-config-files: $(CONFFILES) $(GENFILES)
- $(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
+ $(mkinstalldirs) $(DESTDIR)$(egconfdir)
for f in $(CONFFILES) $(GENFILES); do \
- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir); \
+ if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(egconfdir)/$$f; then \
+ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(egconfdir)"; \
+ $(INSTALL_DATA) $$f $(DESTDIR)$(egconfdir); \
else \
echo "not overwriting $$f"; \
fi; \