pkgsrc/graphics/magicpoint/patches/patch-ap
taca 2615325c03 Update magicpoint to 1.13a.
* Fix build error with xft2 option and graphics/freetype-lib package is
  installed.  Shoud be fix PR pkg/32656.
* Refering PR pkg/38552 adpot some of patches.
* Move PKG_OPTIONS related item to options.mk.
* More pkgsrc clean up.
* Try to reduce compile warnings.


What's new in 1.13a?

    * m17n library support enhancement
    * MacOS support enhancement
    * add new environment variable MGPRC for the path of the .mgprc file.
    * add "psfont" directive to specify the font used by mgp2ps
    * add -g option for mgp2ps to allow users to adjust line distanc
    * add -zoomonclk option for newimage
    * allow to handle gif format images by default
    * many bug fixes

      Dedication

      Magicpoint 1.13a is dedicated to the memory of Dr. Jun-ichiro
      "itojun" Hagino, who was known for his enormous contribution to
      the Internet and the Open Source Software community. He was the
      developer of Magicpoint from its infancy. Magicpoint could not
      exist without his devoted work.

What's new in 1.12a?

    * add %tsystem directive which might be more stable than %xsystem
    * add -rotate option for newimage
    * allow to use non-ASCI filename in slides (use -U to enable this feature)
    * many bug fixes
2008-09-10 13:32:47 +00:00

60 lines
2 KiB
Text

$NetBSD: patch-ap,v 1.1 2008/09/10 13:32:48 taca Exp $
--- contrib/xwintoppm/dsimple.h.orig 1998-02-13 16:48:30.000000000 +0900
+++ contrib/xwintoppm/dsimple.h
@@ -41,25 +41,25 @@ from the X Consortium.
/* Global variables used by routines in just_display.c */
-char *program_name = "unknown_program"; /* Name of this program */
-Display *dpy; /* The current display */
-int screen; /* The current screen */
+extern char *program_name;
+extern Display *dpy;
+extern int screen;
#define INIT_NAME program_name=argv[0] /* use this in main to setup
program_name */
/* Declaritions for functions in just_display.c */
-void Fatal_Error();
-char *Malloc();
-char *Realloc();
-char *Get_Display_Name();
-Display *Open_Display();
-void Setup_Display_And_Screen();
-XFontStruct *Open_Font();
-Pixmap ReadBitmapFile();
-void WriteBitmapFile();
-Window Select_Window_Args();
+void Fatal_Error(char *msg, ...);
+char *Malloc(unsigned int);
+char *Realloc(char *, int);
+char *Get_Display_Name(int *, char **);
+Display *Open_Display(char *);
+void Setup_Display_And_Screen(int *, char **);
+XFontStruct *Open_Font(char *);
+Pixmap ReadBitmapFile(Drawable, char *, int*, int*, int*, int*);
+void WriteBitmapFile(char *, Pixmap, int, int, int, int);
+Window Select_Window_Args(int *, char **);
#define X_USAGE "[host:display]" /* X arguments handled by
Get_Display_Name */
@@ -73,9 +73,10 @@ Window Select_Window_Args();
* Send bugs, etc. to chariot@athena.mit.edu.
*/
-unsigned long Resolve_Color();
-Pixmap Bitmap_To_Pixmap();
-Window Select_Window();
-void out();
-void blip();
-Window Window_With_Name();
+unsigned long Resolve_Color(Window, char *);
+Pixmap Bitmap_To_Pixmap(Display *, Drawable, GC, Pixmap, int, int);
+Window Select_Window(Display *);
+void blip(void);
+Window Window_With_Name(Display *, Window, char *);
+void outl(char *, ...);
+void usage(void);