9ecad91e80
(2003/08/14 - broeker) Cleaned up man page, INSTALL and TODO files. (2003/08/14 - broeker) Have configure check for <regex.h>. Bail out if none found. (2003/08/14 - broeker) New options --help and --version. (2003/06/12 - broeker) New option -v to output progress updates even in line mode. To be used by interface kscope. (2003/06/02 - broeker) Use the basename of files only to test for SCCS/RCS files in -R traversal. (2003/04/29 - broeker) Check that a src file is a regular file before trying to scan it. Change from S_IFDIR/S_IFREG bit tests to macros S_ISDIR/S_ISREG. (2003/03/05 - broeker) Remove '-y' option from pipe call to utility "sort". It's long since deprecated, and some modern versions will barf seeing it. (2003/03/02 - broeker) Don't restrict to 14 character filenames any longer. (2003/01/23 - broeker) Update to latest auto* tools. First step towards integration of GNOME GUI version. (2002/12/11 - broeker) Get rid of deprecated ={...} style actions in egrep.y. Use plain {...} instead. (2002/10/29 - broeker) Fix bug #588671: disprefs was still 0 if only 1 very long reference output shown by curses display. (2002/08/27 - broeker) Fix bug #600494: use mygetenv() for HOME, and provide a fall-back if it's not there.
235 lines
7.4 KiB
Text
235 lines
7.4 KiB
Text
$NetBSD: patch-ad,v 1.5 2005/10/03 15:00:12 wiz Exp $
|
|
|
|
--- contrib/Makefile.in.orig 2003-09-04 18:51:25.000000000 +0200
|
|
+++ contrib/Makefile.in
|
|
@@ -1,8 +1,8 @@
|
|
-# Makefile.in generated by automake 1.7.2 from Makefile.am.
|
|
+# Makefile.in generated by automake 1.9.6 from Makefile.am.
|
|
# @configure_input@
|
|
|
|
-# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002
|
|
-# Free Software Foundation, Inc.
|
|
+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
|
|
+# 2003, 2004, 2005 Free Software Foundation, Inc.
|
|
# This Makefile.in is free software; the Free Software Foundation
|
|
# gives unlimited permission to copy and/or distribute it,
|
|
# with or without modifications, as long as this notice is preserved.
|
|
@@ -21,7 +21,6 @@ pkgdatadir = $(datadir)/@PACKAGE@
|
|
pkglibdir = $(libdir)/@PACKAGE@
|
|
pkgincludedir = $(includedir)/@PACKAGE@
|
|
top_builddir = ..
|
|
-
|
|
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
|
|
INSTALL = @INSTALL@
|
|
install_sh_DATA = $(install_sh) -c -m 644
|
|
@@ -35,7 +34,29 @@ POST_INSTALL = :
|
|
NORMAL_UNINSTALL = :
|
|
PRE_UNINSTALL = :
|
|
POST_UNINSTALL = :
|
|
+build_triplet = @build@
|
|
host_triplet = @host@
|
|
+subdir = contrib
|
|
+DIST_COMMON = README $(srcdir)/Makefile.am $(srcdir)/Makefile.in
|
|
+ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
+am__aclocal_m4_deps = $(top_srcdir)/configure.in
|
|
+am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
|
|
+ $(ACLOCAL_M4)
|
|
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
+CONFIG_HEADER = $(top_builddir)/config.h
|
|
+CONFIG_CLEAN_FILES =
|
|
+SOURCES =
|
|
+DIST_SOURCES =
|
|
+am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
|
|
+am__vpath_adj = case $$p in \
|
|
+ $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
|
|
+ *) f=$$p;; \
|
|
+ esac;
|
|
+am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
|
+am__installdirs = "$(DESTDIR)$(pkgdatadir)"
|
|
+pkgdataDATA_INSTALL = $(INSTALL_DATA)
|
|
+DATA = $(pkgdata_DATA)
|
|
+DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
ACLOCAL = @ACLOCAL@
|
|
AMDEP_FALSE = @AMDEP_FALSE@
|
|
AMDEP_TRUE = @AMDEP_TRUE@
|
|
@@ -99,7 +120,10 @@ ac_ct_STRIP = @ac_ct_STRIP@
|
|
am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
|
|
am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
|
|
am__include = @am__include@
|
|
+am__leading_dot = @am__leading_dot@
|
|
am__quote = @am__quote@
|
|
+am__tar = @am__tar@
|
|
+am__untar = @am__untar@
|
|
bindir = @bindir@
|
|
build = @build@
|
|
build_alias = @build_alias@
|
|
@@ -122,6 +146,7 @@ libdir = @libdir@
|
|
libexecdir = @libexecdir@
|
|
localstatedir = @localstatedir@
|
|
mandir = @mandir@
|
|
+mkdir_p = @mkdir_p@
|
|
oldincludedir = @oldincludedir@
|
|
prefix = @prefix@
|
|
program_transform_name = @program_transform_name@
|
|
@@ -129,18 +154,8 @@ sbindir = @sbindir@
|
|
sharedstatedir = @sharedstatedir@
|
|
sysconfdir = @sysconfdir@
|
|
target_alias = @target_alias@
|
|
-
|
|
-bin_SCRIPTS = ocs
|
|
-
|
|
+pkgdata_DATA = ocs
|
|
EXTRA_DIST = ocs README xcscope webcscope
|
|
-subdir = contrib
|
|
-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
-CONFIG_HEADER = $(top_builddir)/config.h
|
|
-CONFIG_CLEAN_FILES =
|
|
-SCRIPTS = $(bin_SCRIPTS)
|
|
-
|
|
-DIST_SOURCES =
|
|
-DIST_COMMON = README Makefile.am Makefile.in
|
|
all: all-am
|
|
|
|
.SUFFIXES:
|
|
@@ -149,37 +164,30 @@ $(srcdir)/Makefile.in: Makefile.am $(t
|
|
$(AUTOMAKE) --gnu contrib/Makefile
|
|
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
|
|
-binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
|
|
-install-binSCRIPTS: $(bin_SCRIPTS)
|
|
+uninstall-info-am:
|
|
+install-pkgdataDATA: $(pkgdata_DATA)
|
|
@$(NORMAL_INSTALL)
|
|
- $(mkinstalldirs) $(DESTDIR)$(bindir)
|
|
- @list='$(bin_SCRIPTS)'; for p in $$list; do \
|
|
+ test -z "$(pkgdatadir)" || $(mkinstalldirs) "$(DESTDIR)$(pkgdatadir)"
|
|
+ @list='$(pkgdata_DATA)'; for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
- if test -f $$d$$p; then \
|
|
- f=`echo "$$p" | sed 's|^.*/||;$(transform)'`; \
|
|
- echo " $(binSCRIPT_INSTALL) $$d$$p $(DESTDIR)$(bindir)/$$f"; \
|
|
- $(binSCRIPT_INSTALL) $$d$$p $(DESTDIR)$(bindir)/$$f; \
|
|
- else :; fi; \
|
|
+ f=$(am__strip_dir) \
|
|
+ echo " $(pkgdataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgdatadir)/$$f'"; \
|
|
+ $(pkgdataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
|
|
done
|
|
|
|
-uninstall-binSCRIPTS:
|
|
+uninstall-pkgdataDATA:
|
|
@$(NORMAL_UNINSTALL)
|
|
- @list='$(bin_SCRIPTS)'; for p in $$list; do \
|
|
- f=`echo "$$p" | sed 's|^.*/||;$(transform)'`; \
|
|
- echo " rm -f $(DESTDIR)$(bindir)/$$f"; \
|
|
- rm -f $(DESTDIR)$(bindir)/$$f; \
|
|
+ @list='$(pkgdata_DATA)'; for p in $$list; do \
|
|
+ f=$(am__strip_dir) \
|
|
+ echo " rm -f '$(DESTDIR)$(pkgdatadir)/$$f'"; \
|
|
+ rm -f "$(DESTDIR)$(pkgdatadir)/$$f"; \
|
|
done
|
|
-uninstall-info-am:
|
|
tags: TAGS
|
|
TAGS:
|
|
|
|
ctags: CTAGS
|
|
CTAGS:
|
|
|
|
-DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
-
|
|
-top_distdir = ..
|
|
-distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
|
|
|
|
distdir: $(DISTFILES)
|
|
@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
|
|
@@ -210,11 +218,11 @@ distdir: $(DISTFILES)
|
|
done
|
|
check-am: all-am
|
|
check: check-am
|
|
-all-am: Makefile $(SCRIPTS)
|
|
-
|
|
+all-am: Makefile $(DATA)
|
|
installdirs:
|
|
- $(mkinstalldirs) $(DESTDIR)$(bindir)
|
|
-
|
|
+ for dir in "$(DESTDIR)$(pkgdatadir)"; do \
|
|
+ test -z "$$dir" || $(mkinstalldirs) "$$dir"; \
|
|
+ done
|
|
install: install-am
|
|
install-exec: install-exec-am
|
|
install-data: install-data-am
|
|
@@ -226,7 +234,7 @@ install-am: all-am
|
|
installcheck: installcheck-am
|
|
install-strip:
|
|
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
|
- INSTALL_STRIP_FLAG=-s \
|
|
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
|
|
`test -z '$(STRIP)' || \
|
|
echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
|
|
mostlyclean-generic:
|
|
@@ -234,7 +242,7 @@ mostlyclean-generic:
|
|
clean-generic:
|
|
|
|
distclean-generic:
|
|
- -rm -f Makefile $(CONFIG_CLEAN_FILES)
|
|
+ -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
|
|
|
|
maintainer-clean-generic:
|
|
@echo "This command is intended for maintainers to use"
|
|
@@ -244,20 +252,22 @@ clean: clean-am
|
|
clean-am: clean-generic mostlyclean-am
|
|
|
|
distclean: distclean-am
|
|
-
|
|
+ -rm -f Makefile
|
|
distclean-am: clean-am distclean-generic
|
|
|
|
dvi: dvi-am
|
|
|
|
dvi-am:
|
|
|
|
+html: html-am
|
|
+
|
|
info: info-am
|
|
|
|
info-am:
|
|
|
|
-install-data-am:
|
|
+install-data-am: install-pkgdataDATA
|
|
|
|
-install-exec-am: install-binSCRIPTS
|
|
+install-exec-am:
|
|
|
|
install-info: install-info-am
|
|
|
|
@@ -266,7 +276,7 @@ install-man:
|
|
installcheck-am:
|
|
|
|
maintainer-clean: maintainer-clean-am
|
|
-
|
|
+ -rm -f Makefile
|
|
maintainer-clean-am: distclean-am maintainer-clean-generic
|
|
|
|
mostlyclean: mostlyclean-am
|
|
@@ -281,16 +291,16 @@ ps: ps-am
|
|
|
|
ps-am:
|
|
|
|
-uninstall-am: uninstall-binSCRIPTS uninstall-info-am
|
|
+uninstall-am: uninstall-info-am uninstall-pkgdataDATA
|
|
|
|
.PHONY: all all-am check check-am clean clean-generic distclean \
|
|
- distclean-generic distdir dvi dvi-am info info-am install \
|
|
- install-am install-binSCRIPTS install-data install-data-am \
|
|
- install-exec install-exec-am install-info install-info-am \
|
|
- install-man install-strip installcheck installcheck-am \
|
|
+ distclean-generic distdir dvi dvi-am html html-am info info-am \
|
|
+ install install-am install-data install-data-am install-exec \
|
|
+ install-exec-am install-info install-info-am install-man \
|
|
+ install-pkgdataDATA install-strip installcheck installcheck-am \
|
|
installdirs maintainer-clean maintainer-clean-generic \
|
|
mostlyclean mostlyclean-generic pdf pdf-am ps ps-am uninstall \
|
|
- uninstall-am uninstall-binSCRIPTS uninstall-info-am
|
|
+ uninstall-am uninstall-info-am uninstall-pkgdataDATA
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|