pkgsrc/math/qalculate-currency/patches/patch-ab
jlam f025f43fc4 Reorder the linker tests in the configure script so that we test for
C libraries *before* we throw the AC_LANG([C++]) switch.  This makes
the generated configure script use the C compiler/linker instead of
the C++ compiler/linker when running tests.  This avoids errors like
these based on not correctly getting the function signature correct:

conftest.cc:36: error: nonnull argument with out-of-range operand
	number (arg 1, operand 2)

This error was causing the configure script to not detect *gettext()
routines and not building and installing the *.mo files.  This fixes
the error noted in the bulk build results:

    http://mail-index.netbsd.org/pkgsrc-bulk/2006/06/20/0000.html
2006-06-22 18:52:00 +00:00

72 lines
2.7 KiB
Text

$NetBSD: patch-ab,v 1.1 2006/06/22 18:52:00 jlam Exp $
--- configure.in.orig 2006-04-18 03:13:20.000000000 -0400
+++ configure.in
@@ -55,6 +55,33 @@ fi
changequote([,])dnl
+dnl -------------------------------------
+dnl | internationalization (i18n) support |------------------------------------
+dnl -------------------------------------
+
+GETTEXT_PACKAGE=qalculate-currency
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
+
+dnl Please keep this in alphabetical order
+ALL_LINGUAS="nl sv"
+AM_GLIB_GNU_GETTEXT
+
+dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
+AC_MSG_CHECKING(locale directory)
+if test "x$prefix" = "xNONE"; then
+ PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
+else
+ PACKAGE_LOCALE_DIR=$prefix/share/locale
+fi
+
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
+ [The directory in which qalculate's locale data will be stored])
+ AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
+
+INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
+AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
+
dnl --------------------------------
dnl | check for neccessary libraries |-----------------------------------------
dnl --------------------------------
@@ -89,33 +116,6 @@ PKG_CHECK_MODULES(QALCULATE, [
AC_SUBST(QALCULATE_CFLAGS)
AC_SUBST(QALCULATE_LIBS)
-dnl -------------------------------------
-dnl | internationalization (i18n) support |------------------------------------
-dnl -------------------------------------
-
-GETTEXT_PACKAGE=qalculate-currency
-AC_SUBST(GETTEXT_PACKAGE)
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
-
-dnl Please keep this in alphabetical order
-ALL_LINGUAS="nl sv"
-AM_GLIB_GNU_GETTEXT
-
-dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
-AC_MSG_CHECKING(locale directory)
-if test "x$prefix" = "xNONE"; then
- PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
-else
- PACKAGE_LOCALE_DIR=$prefix/share/locale
-fi
-
-AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
- [The directory in which qalculate's locale data will be stored])
- AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
-
-INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
-AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
-
dnl --------
dnl | output |-----------------------------------------------------------------
dnl --------