635c6af9fc
Note that there is a bug in 4.11 (also present in recent 4.6 and 4.8) which causes an infrequent assert failure when running NetBSD PV guests. The root cause has not been found, but a workaround is inclued which doesn't seems to have ill effects. See xenkernel411/patches/patch-zz-bouyer for details.
15 lines
543 B
Makefile
15 lines
543 B
Makefile
$NetBSD: patch-xen_arch_x86_boot_build32.mk,v 1.1 2018/07/24 13:40:11 bouyer Exp $
|
|
linux's toolchain doesn't generate a .eh_frame section but NetBSD does.
|
|
remove it.
|
|
|
|
--- xen/arch/x86/boot/build32.mk.orig 2018-04-17 19:21:31.000000000 +0200
|
|
+++ xen/arch/x86/boot/build32.mk 2018-04-23 13:29:47.000000000 +0200
|
|
@@ -25,7 +25,7 @@
|
|
exit $$(expr $$idx + 1);; \
|
|
esac; \
|
|
done
|
|
- $(OBJCOPY) -O binary -R .got.plt $< $@
|
|
+ $(OBJCOPY) -O binary -R .got.plt -R .eh_frame $< $@
|
|
|
|
%.lnk: %.o
|
|
$(LD) $(LDFLAGS_DIRECT) -N -T build32.lds -o $@ $<
|