539cc301cc
devel/g-wrap196 instead. Changes since 1.9.6: Version 1.9.8 - New feature: function flags. At the moment there is a single flag specifying whether to leave "Guile mode" when calling the wrapper functions. See the Guile manual on "scm_without_guile" for more information. - Don't rely on libc to provide (v)asprintf, take the implementation from gnulib. - The minimal GLib bindings now build against GLib 2.x. However, their use is deprecated in favour of the much more complete GLib bindings in guile-gnome (http://www.gnu.org/software/guile-gnome/). Version 1.9.7 - The shared libraries now reside in $(pkglibdir)/modules (e.g. /usr/lib/g-wrap/modules). - Users are now allowed to chose in which module generic functions should be defined. - New feature: aggregated typespecs. See the node `Wrapping a C Function' of the manual for details. - Users can now specify a free and a mark function, as well as an equality predicate for wrapped C types (WCTs) in `wrap-as-wct!'. - Improved documentation with an API reference (yet to be finished). - Several bugfixes.
13 lines
687 B
Text
13 lines
687 B
Text
$NetBSD: patch-ad,v 1.3 2007/05/17 23:59:35 gdt Exp $
|
|
|
|
--- guile/examples/Makefile.am.orig 2007-04-13 13:35:30.000000000 -0400
|
|
+++ guile/examples/Makefile.am
|
|
@@ -5,7 +5,7 @@ libmiscutils_la_SOURCES = miscutils.c mi
|
|
|
|
lib_LTLIBRARIES += libgw-guile-miscutils.la
|
|
libgw_guile_miscutils_la_SOURCES = miscutils-guile.c miscutils-guile.h gw-miscutils.c
|
|
-libgw_guile_miscutils_la_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/guile
|
|
+libgw_guile_miscutils_la_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/guile -I$(top_srcdir)/libffi/include
|
|
libgw_guile_miscutils_la_LDFLAGS = -module
|
|
libgw_guile_miscutils_la_LIBADD = libmiscutils.la \
|
|
$(top_builddir)/guile/g-wrap/libgwrap-guile-runtime.la \
|