5af6b9a9c1
Since 2.0: * Fix scrub abort on files/disks > 2G in size (issue 19) This was introduced in 2.5.0 and the failure is quick and obvious. * Fix loss of precision in disk size approximation (issue 18) * Add -t option to disable creation of thread to generate randomness in parallel with I/O. * Prepare source for a libscrub api (work in progress) * Cosmetic changes to man page and help output. * Generate randomness and do I/O in parallel [Richard B. Hill] * Replace O_SYNC with O_DIRECT+fsync+posix_fadvise [H. Peter Anvin] This produces a significant performance improvement, at least on Linux. * Add support for RDRAND instr. [H. Peter Anvin] * Use <stdbool.h> if the system has it [H. Peter Anvin] * Fix incorrect assertion in scrub --dirent handling (issue 9) [Peter Hyman] * Clean up tmp files after scrub --freespace (issue 9) [Peter Hyman] * Allow scrub --pattern=custom="string" (issue 11) [Peter Hyman] Allow C style numerical escapes in string: \nnn (octal) and \xnn (hex). This is a single-pass sequence with a custom pattern. * Change default buffer size from 1m to 4m [H. Peter Anvin] * Avoid closing and re-opening /dev/urandom [H. Peter Anvin] * Fix bug in pfitzner7 pattern def and add fillff, fillzero methods (issue 8) [Peter Hyman] * Change dod method to perform random pass first and skip extra pass. * Add --help option that lists available scrub methods. * Make dist tarball work with rpmbuild -ta. * Added usarmy, pfitzner7, and pfitzner33 methods. * Added -L option to not follow symbolic links [Timothy Boronczyk] * Treat a zero return from write(2) as an error. * New patterns: - random2: two random passes - schneier (one 0x00 pass, one 0xff pass, and five random passes) [Joe] * Add --pattern random (one random pass) mode. * Portability fixes for Slackware [Timothy Boronczyk] * Fix bug where scrub --remove on a zero length file would abort without removing the file. Issue a warning and remove it. * Fix a bug where some data from the original file could appear in the first disk block after a verified scrub when running without the -S (--no-signature) option.
15 lines
519 B
Text
15 lines
519 B
Text
$NetBSD: patch-src_Makefile.am,v 1.1 2013/12/11 19:07:47 prlw1 Exp $
|
|
|
|
- Make unimplemented getsize() function match prototype in getsize.h.
|
|
- Use ioctl names (feature tests) rather than OS names.
|
|
XXX for SIOC_CAPACITY consider using SIOC_STORAGE_CAPACITY.
|
|
- Implement getsize() based on DIOCGDISKINFO ioctl.
|
|
|
|
--- src/Makefile.am.orig 2013-12-11 17:24:13.000000000 +0000
|
|
+++ src/Makefile.am
|
|
@@ -23,4 +23,4 @@ scrub_SOURCES = \
|
|
util.c \
|
|
util.h
|
|
|
|
-scrub_LDADD = $(LIBPTHREAD)
|
|
+scrub_LDADD = $(LIBPTHREAD) $(LIBPROP)
|