* Read-only PKCS11 provider built-in to hx509. * Better compatibilty with Windows 2008 Server pre-releases and Vista. * Add RFC3526 modp group14 as default. * Handle [kdc] database = { } entries without realm = stanzas. * Add gss_pseudo_random() for mechglue and krb5. * Make session key for the krbtgt be selected by the best encryption type of the client. * Better interoperability with other PK-INIT implementations. * Alias support for inital ticket requests. * Make ASN.1 library less paranoid to with regard to NUL in string to make it inter-operate with MIT Kerberos again. * PK-INIT support. * HDB extensions support, used by PK-INIT. * New ASN.1 compiler. * GSS-API mechglue from FreeBSD. * Updated SPNEGO to support RFC4178. * Support for Cryptosystem Negotiation Extension (RFC 4537). * A new X.509 library (hx509) and related crypto functions. * A new ntlm library (heimntlm) and related crypto functions. * KDC will return the "response too big" error to force TCP retries for large (default 1400 bytes) UDP replies. This is common for PK-INIT requests. * Libkafs defaults to use 2b tokens. * krb5_kuserok() also checks ~/.k5login.d directory for acl files. * Fix memory leaks. * Bugs fixes
14 lines
399 B
Text
14 lines
399 B
Text
$NetBSD: patch-ac,v 1.3 2008/02/28 08:14:41 jlam Exp $
|
|
|
|
--- configure.in.orig 2008-01-24 08:13:51.000000000 -0500
|
|
+++ configure.in
|
|
@@ -16,9 +16,6 @@ AC_PROG_CPP
|
|
|
|
AC_PREFIX_DEFAULT(/usr/heimdal)
|
|
|
|
-test "$sysconfdir" = '${prefix}/etc' && sysconfdir='/etc'
|
|
-test "$localstatedir" = '${prefix}/var' && localstatedir='/var/heimdal'
|
|
-
|
|
AC_CANONICAL_HOST
|
|
CANONICAL_HOST=$host
|
|
AC_SUBST(CANONICAL_HOST)
|