pkgsrc/www/apache6/patches/patch-ai
jlam 2ed7a86f42 Minimize the diffs between the apache and apache6 packages:
- Whitespace changes to Makefile
- From the commit log for apache/Makefile:

Don't do the dance with ROOT_GROUP.  Apache extension modules installed by
apxs are now installed with "${INSTALL} -c -o ${LIBOWN} -g ${LIBGRP}",
which should do the right thing regardless of the platform.  ${INSTALL} is
replaced with the full path to the install program used by pkgsrc, which
should be /usr/bin/install on NetBSD, and /usr/ucb/install on Solaris.

This should fix pkg/14232 by Pierre Bourgin.
2001-10-22 18:10:28 +00:00

14 lines
498 B
Text

$NetBSD: patch-ai,v 1.3 2001/10/22 18:10:29 jlam Exp $
--- src/support/apxs.pl.orig Sat Jun 9 01:06:57 2001
+++ src/support/apxs.pl Sat Jun 9 01:11:28 2001
@@ -459,8 +459,7 @@
if ($^O ne "MSWin32") {
$t =~ s|^.+/([^/]+)$|$1|;
if ($opt_i) {
- push(@cmds, "cp $f $CFG_LIBEXECDIR/$t");
- push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
+ push(@cmds, "@INSTALL@ $f $CFG_LIBEXECDIR/$t");
}
}
else {