pkgsrc/graphics/jasper/patches/patch-CMakeLists.txt
adam c838c81330 Changes 2.0.10:
Fixed a problem in the JP2 encoder that caused a null pointer dereference when no ICC profile data is available (e.g., in the case of an unknown color space).
2017-02-21 18:24:20 +00:00

18 lines
611 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.1 2017/02/21 18:24:20 adam Exp $
Remove the weird hack.
--- CMakeLists.txt.orig 2017-02-21 17:54:13.000000000 +0000
+++ CMakeLists.txt
@@ -55,11 +55,7 @@ set(JAS_SO_MINOR 0)
set(JAS_SO_RELEASE 0)
# This is a temporary hack for OSX that should be removed when JAS_SO_VERSION
# is next incremented.
-if (MACOSX)
-set(JAS_SO_NAME "5.${JAS_SO_MINOR}.${JAS_SO_RELEASE}")
-else()
set(JAS_SO_NAME "${JAS_SO_VERSION}.${JAS_SO_MINOR}.${JAS_SO_RELEASE}")
-endif()
message("Shared library ABI version: ${JAS_SO_VERSION}")
message("Shared library build version: ${JAS_SO_NAME}")