ff57234978
work for some users (sparc64 support, for example, is busted and won't appear again until firefox-5.0).
29 lines
555 B
Text
29 lines
555 B
Text
$NetBSD: patch-mp,v 1.1.1.1 2011/04/19 11:16:08 tnn Exp $
|
|
|
|
--- media/libsydneyaudio/src/Makefile.in.orig 2010-07-13 19:10:28.000000000 +0000
|
|
+++ media/libsydneyaudio/src/Makefile.in
|
|
@@ -83,6 +83,24 @@ CSRCS = \
|
|
$(NULL)
|
|
endif
|
|
|
|
+ifeq ($(OS_ARCH),DragonFly)
|
|
+CSRCS = \
|
|
+ sydney_audio_oss.c \
|
|
+ $(NULL)
|
|
+endif
|
|
+
|
|
+ifeq ($(OS_ARCH),FreeBSD)
|
|
+CSRCS = \
|
|
+ sydney_audio_oss.c \
|
|
+ $(NULL)
|
|
+endif
|
|
+
|
|
+ifeq ($(OS_ARCH),NetBSD)
|
|
+CSRCS = \
|
|
+ sydney_audio_oss.c \
|
|
+ $(NULL)
|
|
+endif
|
|
+
|
|
ifeq ($(OS_ARCH),WINNT)
|
|
OS_LIBS += winmm.lib
|
|
endif
|