ef091fdc86
Notable changes include: * Dynamic loading now works on NetBSD ELF systems. * Integration of SRFI-9 (records) * Accepts mailto: links in the browser * <Scroll-Frame>, <Toolbar> STklos classes. * Integration of some finals SRFI (0, 2, 6, 8) * define-syntax (but not let-syntax and let-syntax*) * New License Policy (request for commercial apps no more needed). * A console mode (which is used by default on Windows, but can be used with the -console option on Unix) * A new editor with Scheme fontification and indentation * New kind of ports: virtual ports * All the code dealing with files has been rewritten. * Tk level is 8.0.3 (the latest stable Tk release) * New STklos Classes: + <Hierarchy-tree> and <Hierarchy-item> to draw hierarchy such as files/directories, class/metaclasses ... + <Notepad> to define ... notepads + <Scheme-text> which extends <Text> to "font-lockify" Scheme buffers * Method and generic function editor * A class browser (type "(class-browser)" to access it) * some new manual pages * Base64 Encoding/Decoding extension * Locale extension to treat strings and character using locale information * Better installation scripts (+ some corrections) * Lot of bug fixes.
23 lines
951 B
Text
23 lines
951 B
Text
$NetBSD: patch-ab,v 1.2 2003/05/10 00:26:33 jtb Exp $
|
|
|
|
--- Demos/Makefile.orig
|
|
+++ Demos/Makefile
|
|
@@ -34,13 +34,15 @@
|
|
do \
|
|
chmod 0755 $(DEMODIR)/`basename $$i`; \
|
|
done
|
|
- mkdir $(DEMODIR)/Html-Demos; chmod 0755 $(DEMODIR)/Html-Demos
|
|
+ -mkdir $(DEMODIR)/Html-Demos
|
|
+ -chmod 0755 $(DEMODIR)/Html-Demos
|
|
cp Html-Demos/*.html $(DEMODIR)/Html-Demos
|
|
chmod 0644 $(DEMODIR)/Html-Demos/*.html
|
|
- mkdir $(DEMODIR)/Html-Demos/Images; chmod 0755 $(DEMODIR)/Html-Demos/Images
|
|
+ -mkdir $(DEMODIR)/Html-Demos/Images
|
|
+ -chmod 0755 $(DEMODIR)/Html-Demos/Images
|
|
cp Html-Demos/Images/*.gif $(DEMODIR)/Html-Demos/Images
|
|
chmod 0644 $(DEMODIR)/Html-Demos/Images/*
|
|
- (cd $(DEMODIR)/Html-Demos; ln -s ../amib.stklos ../stklos-widgets .)
|
|
+ (cd $(DEMODIR)/Html-Demos; ln -fs ../amib.stklos ../stklos-widgets .)
|
|
-if [ ! -d $(DEMODIR)lib ] ; then mkdir -p $(DEMODIR)/lib; fi
|
|
$(CP) ../Contrib/STk-wtour/lib/*.xbm $(DEMODIR)/lib
|
|
chmod 0644 $(DEMODIR)/lib/*
|