pkgsrc/databases/unixodbc/patches/patch-al
jnemeth df758f2275 Update to unixODBC 2.3.0:
2.3.0

	* Try and rationalise the way the connection process find the driver
	  version and supported functions
	* Sort out problem in isql with blank lines
	* Stop libthread from being used under AIX
	* Move the GUI parts off into a new project
		http://sourceforge.net/projects/unixodbc-gui-qt/
	* Strip out the GUI parts. I have also removed the spec files
	  as they will need redoing,
	* Move the Test parts off into a new project
		http://sourceforge.net/projects/unixodbc-test/
	* Add interface into odbcinstQ to allow for a dialog if SQLDriverConnect
	  is called without a DSN= (as the MS spec)
	* Allow the setting of a default Threading level in the ODBC section
          of odbcinst.ini
        * Change double format string in Postgre7.1 driver
	* Add missing CR to output of odbcinst
	* add fixes to MiniSQL driver
	* Add missing .y in nn driver, now I need to get it to work
    * Assoured bux fixes and format problems, thanks Tom
	* SQLBindCol on metadata calls was incorrectly going via the cursor lib if it
	* fix isql problem with nested definitions.
	  was enabled
	* Add configure option to enable building of driver config libs
	* Shift build to using config.h, the compile lines were so big it was hard to
	  see warnings
	* Fix bug in isql when using -b option.
    * Check attribute values when setting connection and statement attrs
    * Check for valid pointers in SQLGetInfo(W) and SQLGetFunctions
    * Add extra checks for states in SQLCopyDesc
    * Add --enable-stricterror option to allow compliance with the error reporting
      definition, driver errors don't have the unixODBC prefix
    * Check for statements in the NEED_DATA state when calling SQLEndTran
    * Extra error check for SQLPutData
    * Check handle type in SQLEndTran
    * Prevent seg fault if there are no driver error functions
    * the -n option to isql was not working correctly
    * Stripped out all the bespoke LDTL configure stull, not just what libtoolize
      provides
    * Fix problem where ansi_to_unicode_alloc didn't leave space for the NULL
      and could cause memory corruption
    * Add the ODBC 3.80 additions that MS have produced. I am sure I remember
      the standard being given to XOpen, what do I know :-)
    * Change the file open mode for the ini file from w to w+ just in case the
      original open failed but the file did exist
    * Fix configure problem preventing the CHAR encoding from being passed
    * Remove white spave from ini write, not all drivers use unixODBC ini functions
      and can handle the spaces
    * Update config.guess to current GNU version including support for AIX6
    * Create SVN repository at sourceforge
    * Add cast to fix problem in SQLSetConnectOption
    * Fix SQLINTEGER<->SQLLEN conversion broblem in SQLNativeSQL
    * Fix bug that stopped setting SQL_ATTR_CONCURRENCY to SQL_CONCUR_VALUES
    * Change minor version number because of the SQLLEN change
    * Remove unintended trailing white space from log generation
2010-05-03 02:10:43 +00:00

13 lines
536 B
Text

$NetBSD: patch-al,v 1.1 2010/05/03 02:10:43 jnemeth Exp $
--- cur/Makefile.in.orig 2010-04-26 02:28:43.000000000 +0000
+++ cur/Makefile.in
@@ -388,7 +388,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
$(am__aclocal_m4_deps):
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
@$(NORMAL_INSTALL)
- test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
+ test -z "$(DESTDIR)$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
@list='$(lib_LTLIBRARIES)'; test -n "$(libdir)" || list=; \
list2=; for p in $$list; do \
if test -f $$p; then \