Prior to this change all USE_TOOLS were already present except "perl". That blocked the generation of both man pages and HTML documentation. Also handle the append of configure's --progs-suffix number to address coexistence of multiple ffmpeg versions man pages (done via patch-doc_Makefile). Bump PKGREVISION.
31 lines
1.5 KiB
Text
31 lines
1.5 KiB
Text
$NetBSD: patch-doc_Makefile,v 1.1 2016/04/28 09:20:53 leot Exp $
|
|
|
|
Honor --prog-suffix configure option also for man pages.
|
|
|
|
--- doc/Makefile.orig 2016-02-01 00:52:15.000000000 +0000
|
|
+++ doc/Makefile
|
|
@@ -14,8 +14,8 @@ COMPONENTS-$(CONFIG_AVFORMAT) += ffmpe
|
|
COMPONENTS-$(CONFIG_AVDEVICE) += ffmpeg-devices
|
|
COMPONENTS-$(CONFIG_AVFILTER) += ffmpeg-filters
|
|
|
|
-MANPAGES1 = $(AVPROGS-yes:%=doc/%.1) $(AVPROGS-yes:%=doc/%-all.1) $(COMPONENTS-yes:%=doc/%.1)
|
|
-MANPAGES3 = $(LIBRARIES-yes:%=doc/%.3)
|
|
+MANPAGES1 = $(AVPROGS-yes:%=doc/%$(PROGSSUF).1) $(AVPROGS-yes:%=doc/%-all$(PROGSSUF).1) $(COMPONENTS-yes:%=doc/%$(PROGSSUF).1)
|
|
+MANPAGES3 = $(LIBRARIES-yes:%=doc/%$(PROGSSUF).3)
|
|
MANPAGES = $(MANPAGES1) $(MANPAGES3)
|
|
PODPAGES = $(AVPROGS-yes:%=doc/%.pod) $(AVPROGS-yes:%=doc/%-all.pod) $(COMPONENTS-yes:%=doc/%.pod) $(LIBRARIES-yes:%=doc/%.pod)
|
|
HTMLPAGES = $(AVPROGS-yes:%=doc/%.html) $(AVPROGS-yes:%=doc/%-all.html) $(COMPONENTS-yes:%=doc/%.html) $(LIBRARIES-yes:%=doc/%.html) \
|
|
@@ -114,10 +114,10 @@ doc/%-all.pod: doc/%.texi $(SRC_PATH)/do
|
|
$(Q)$(TEXIDEP)
|
|
$(M)perl $(SRC_PATH)/doc/texi2pod.pl -Dconfig-all=yes -Idoc $< $@
|
|
|
|
-doc/%.1 doc/%.3: TAG = MAN
|
|
-doc/%.1: doc/%.pod $(GENTEXI)
|
|
+doc/%$(PROGSSUF).1 doc/%$(PROGSSUF).3: TAG = MAN
|
|
+doc/%$(PROGSSUF).1: doc/%.pod $(GENTEXI)
|
|
$(M)pod2man --section=1 --center=" " --release=" " --date=" " $< > $@
|
|
-doc/%.3: doc/%.pod $(GENTEXI)
|
|
+doc/%$(PROGSSUF).3: doc/%.pod $(GENTEXI)
|
|
$(M)pod2man --section=3 --center=" " --release=" " --date=" " $< > $@
|
|
|
|
$(DOCS) doc/doxy/html: | doc/
|