66d3c5ee50
The main changes is to support revision 4 modems (silver cycle helmet/beetle) and to use the threaded pppo3 if native threads are available. Tested on: - stringray by David Brownlee (abs@) and me - purple cycle helmet/beetle by David Brownlee - silver cycle helment/beetle by me
16 lines
567 B
Text
16 lines
567 B
Text
$NetBSD: patch-ab,v 1.4 2004/12/23 18:11:18 skrll Exp $
|
|
|
|
--- configure.in.orig 2004-09-29 21:56:31.000000000 +0100
|
|
+++ configure.in
|
|
@@ -112,8 +112,9 @@ case "$host" in
|
|
AC_DEFINE(FREEBSD)
|
|
;;
|
|
*-netbsd*)
|
|
- st_compile="modem_run pppoa2"
|
|
- AC_MSG_WARN(pthread lib not yet supported)
|
|
+ st_compile="modem_run pppoa2 pppoa3"
|
|
+ AC_CHECK_LIB(pthread, pthread_create, THREAD_LIBS="-pthread",
|
|
+ [AC_MSG_WARN(pthread lib wasn't found : pppoa3 won't be compiled); st_compile="modem_run pppoa2"])
|
|
DOCDIR="doc-bsd"
|
|
PUSB_SOURCE="pusb-bsd.c"
|
|
AC_DEFINE(NETBSD)
|