pkgsrc/devel/id-utils/patches/patch-ae
seb 1034334372 - Fix build failure - exposed after lastest modification of
../../devel/gettext-lib/buildlink.mk - due to incorrect usage of @INTLIBS@ in
  Automake's prog_LDADD variable. Thanks Johnny Lam for hints and explanations!
- While here get ride off build dependencies on auto* tools and GNU make by
  using a new set of patches and AUTOMAKE_OVERRIDE.
  Note: new Makefile.am files and hence their patches were generated with
  automake-1.1b!
- sort PLIST and use same `install-info' arguments as those generated by
  `make print-PLIST'.
- Fix broken dependencies when USE_XEMACS is defined.
2001-11-03 09:59:35 +00:00

28 lines
780 B
Text

$NetBSD: patch-ae,v 1.2 2001/11/03 09:59:36 seb Exp $
--- lisp/Makefile.am.orig Sun Jun 2 07:15:31 1996
+++ lisp/Makefile.am
@@ -1,10 +1,21 @@
## Process this file with automake to create Makefile.in
+# Makefile.in's patch is produced after regen from Makefile.am with
+# automake-1.1b
+
EXTRA_DIST = id-utils.el elisp-comp
-elc_SCRIPTS = id-utils.elc
+elc_DATA = id-utils.elc
elcdir = @LISPDIR@
+eldir = @LISPDIR@
SUFFIXES = .el .elc
+.SUFFIXES: .el .elc
.el.elc:
@echo "WARNING: Warnings can be ignored. :-)"
- $(SHELL) $(srcdir)/elisp-comp $<
+ $(BSD_SETENV) EMACS=@EMACS@ $(SHELL) $(srcdir)/elisp-comp $<
+
+install-data-hook:
+ if test -f id-utils.elc; then \
+ $(mkinstalldirs) $(eldir); \
+ $(INSTALL_DATA) $(srcdir)/id-utils.el $(eldir)/id-utils.el; \
+ fi