042a29a462
----------------- Released 2.2, 11/14/02 ----------------------- 11/19/02 (bug fix) Fixed problem with SnackAudioPlayed() on Windows, return value could roll over after lengthy sound output. (Wilkason) 1/16/03 (enhancement) Canvas items now work on Mac OS X, also added Makefile hardcoded for Tcl8.4.1. 1/24/03 (new feature) Support for standard configure/make build systom on Mac OS X. 1/24/03 (new feature) Core Audio support for Mac OS X. 2/06/03 (new feature) Improved build support for Mac OS X. (Steffen) 2/10/03 (new feature) New sample encoding format Lin24Packed. 2/11/03 (bug fix) Fixed problem with the ESPS pitch tracker. 2/10/03 (new feature) Snack libraries compiled for Tcl/Tk 8.4 now work with earlier stub versions as well. ----------------- Released 2.2.1, 2/21/03 ----------------------- 2/28/03 (new feature) Included project files for MSVC++ 7.0. 3/3/03 (new feature) 24-bit recording supported on 24-bit capable hardware. 3/5/03 (change) Updated the release to use Tcl/Tk 8.4 as default 3/6/03 (bug fix) Fixed convert command for conversions involving Lin24 and Lin32 sample encodings. 5/8/03 (enhancement) Several improvements to the MP3 decoder. (Wilkason) 5/8/03 (enhancement) Enhanced streaming support regarding slow networks and playback of long tracks. (Wilkason) ----------------- Released 2.2.2, 5/9/03 ----------------------- 8/5/03 (bug fix) Fixed bug in audio code for Mac OS X. 8/26/03 (enhancement) On Sun machines the environment variable AUDIODEV is now used. 8/27/03 (new feature) Updated Snack script compiler, wrap.tcl, to use TclKit. 8/27/03 (new feature) New sound commands powerSpectrum and speatures. 8/29/03 (change) Changed distribution format for Windows. ----------------- Released 2.2.3, 8/29/03 ----------------------- 9/9/03 (bug fix) Bug fix in the AIFF header parsing routine. 11/20/03 (bug fix) Bug fix in the pitch command for short sounds (ESPS method) (Theado) 11/20/03 (new feature) Easier Python installation through setup.py script. (Owen) 2/6/04 (bug fix) Bug fix for Windows XP which caused a crash when using USB sound cards. 2/6/04 (bug fix) Bug fix for Macintosh OS X audio which caused echo effect. 2/6/04 (bug fix) Bug fix for Linux OSS which handles audio device busy better. (Wilkason) 2/6/04 (enhancement) Added ability to set Windows DirectSound flags through Tcl integer variables. DSBCAPS_FLAG for DSBCAPS_* and DSSCL_FLAG for IDirectSound_SetCooperativeLevel(). (Wilkason) ----------------- Released 2.2.4, 2/9/04 ----------------------- 3/12/04 (bug fix) Fixed memory leak in pitch command. (DeJong) 3/23/04 (change) Updates for the ALSA 1.0 API. (Max) 3/23/04 (enhancement) Modifications to allow build on 64-bit platforms. (Max) 4/9/04 (new feature) Mingw support added. (DeJong) 4/9/04 (bug fix) Fixes for playback clean-up. (DeJong) 4/21/04 (enhancement) Support for playback (in addition to recording) of more than two channels on Windows. 5/3/04 (bug fix) MME audio device selection corrected on Windows. 5/5/04 (bug fix) Corrected bug which made it impossible to "stop" queued sounds. ----------------- Released 2.2.5, 5/5/04 ----------------------- 5/12/04 (bug fix) Corrected sample command for use with 24-bit integer samples. 5/15/04 (bug fix) Corrected sample command, now raises an error when more sample values than number of channels are given. 6/8/04 (bug fix) Correction for Lin24 format on Windows. (Schnarr) 6/14/04 (bug fix) Corrected mean calculation for dBPowerSpectrum. 6/14/04 (bug fix) Added out-of-bounds checks SnackCopySamples(), Snack_PutSoundData(), and Snack_GetSoundData(). (DeJong) ----------------- Released 2.2.6, 6/15/04 ----------------------- 6/18/04 (bug fix) Added out-of-bounds check in ReadSound(). (DeJong) 6/24/04 (bug fix) Several fixes regarding spectral estimation. 6/24/04 (new feature) New option -regressionorder for the speatures command. ----------------- Released 2.2.7, 6/24/04 ----------------------- 8/18/02 (bug fix) Fix for configure. (Allaert) 8/18/02 (bug fix) Fixes for Mingw. (DeJong) 8/18/02 (bug fix) Fixed the -windowtype option to formant to actually use the window names given in the manual. 8/18/02 (bug fix) Fixed the speatures command to update sound properties correctly. 9/22/04 (change) Increased the number of default shades of grey for spectrograms to 256. 9/23/02 (bug fix) Fixed problem with sound I/O using Windows DirectSound. (DeJong) 9/24/04 (new feature) New command lastIndex, which returns last sample index of a sound object. ----------------- Released 2.2.8, 9/30/04 -----------------------
17 lines
571 B
Text
17 lines
571 B
Text
$NetBSD: patch-ac,v 1.2 2004/11/27 10:48:51 gson Exp $
|
|
|
|
--- configure.orig 2004-04-08 21:07:42.000000000 -0700
|
|
+++ configure
|
|
@@ -2302,10 +2302,12 @@
|
|
s,@SHLIB_LD@,$SHLIB_LD,;t t
|
|
s,@SHLIB_SUFFIX@,$SHLIB_SUFFIX,;t t
|
|
s,@XINCLUDES@,$XINCLUDES,;t t
|
|
+s,@TCL_PREFIX@,$TCL_PREFIX,;t t
|
|
s,@TCL_INCLUDE_SPEC@,$TCL_INCLUDE_SPEC,;t t
|
|
s,@TCL_LIB_SPEC@,$TCL_LIB_SPEC,;t t
|
|
s,@TK_LIB_SPEC@,$TK_LIB_SPEC,;t t
|
|
s,@TCL_SRC_DIR@,$TCL_SRC_DIR,;t t
|
|
+s,@TK_PREFIX@,$TK_PREFIX,;t t
|
|
s,@TK_SRC_DIR@,$TK_SRC_DIR,;t t
|
|
s,@TK_LIBS@,$TK_LIBS,;t t
|
|
s,@SNACK_INSTALL_PATH@,$SNACK_INSTALL_PATH,;t t
|