bba5f17b29
* Enforce restrictions in plperl using an opmask applied to the whole interpreter, instead of using "Safe.pm" * Prevent PL/Tcl from executing untrustworthy code from pltcl_modules * Fix data corruption during WAL replay of ALTER ... SET TABLESPACE * Fix possible crash if a cache reset message is received during rebuild of a relcache entry * Apply per-function GUC settings while running the language validator for the function * Do constraint exclusion for inherited "UPDATE" and "DELETE" target tables when constraint_exclusion = partition * Do not allow an unprivileged user to reset superuser-only parameter settings * Avoid possible crash during backend shutdown if shutdown occurs when a CONTEXT addition would be made to log entries * Fix erroneous handling of %r parameter in recovery_end_command * Ensure the archiver process responds to changes in archive_command as soon as possible * Fix pl/pgsql's CASE statement to not fail when the case expression is a query that returns no rows * Update pl/perl's "ppport.h" for modern Perl versions * Fix assorted memory leaks in pl/python * Handle empty-string connect parameters properly in ecpg * Prevent infinite recursion in psql when expanding a variable that refers to itself * Fix psql's \copy to not add spaces around a dot within \copy (select ...) * Avoid formatting failure in psql when running in a locale context that doesn't match the client_encoding * Fix unnecessary "GIN indexes do not support whole-index scans" errors for unsatisfiable queries using "contrib/intarray" operators * Ensure that "contrib/pgstattuple" functions respond to cancel interrupts promptly * Make server startup deal properly with the case that shmget() returns EINVAL for an existing shared memory segment * Avoid possible crashes in syslogger process on Windows * Deal more robustly with incomplete time zone information in the Windows registry * Update the set of known Windows time zone names * Update time zone data files to tzdata release 2010j for DST law changes in Argentina, Australian Antarctic, Bangladesh, Mexico, Morocco, Pakistan, Palestine, Russia, Syria, Tunisia; also historical corrections for Taiwan. Also, add PKST (Pakistan Summer Time) to the default set of timezone abbreviations.
15 lines
367 B
Text
15 lines
367 B
Text
$NetBSD: patch-ad,v 1.3 2010/05/20 12:36:39 adam Exp $
|
|
|
|
--- src/pl/plperl/GNUmakefile.orig 2010-05-20 07:51:50.000000000 +0000
|
|
+++ src/pl/plperl/GNUmakefile
|
|
@@ -53,9 +53,7 @@ PSQLDIR = $(bindir)
|
|
include $(top_srcdir)/src/Makefile.shlib
|
|
|
|
|
|
-all: all-lib
|
|
-
|
|
-plperl.o: plperl_opmask.h
|
|
+all: plperl_opmask.h all-lib
|
|
|
|
plperl_opmask.h: plperl_opmask.pl
|
|
$(PERL) $< $@
|