pkgsrc/net/xipdump/patches/patch-aa
wiz 091b07909e Fix configure script to first determine if we are on a bigendian system or
not, and only then set the corresponding variables.
Addresses pkg/9803.
2000-09-09 19:23:24 +00:00

43 lines
954 B
Text

$NetBSD: patch-aa,v 1.2 2000/09/09 19:23:25 wiz Exp $
--- configure.in.orig Wed Dec 22 09:50:40 1999
+++ configure.in
@@ -55,6 +55,8 @@
LDFLAGS="$LDFLAGS -L$PCAP_LIBPATH"
fi
+if false
+then
MG_LIBNET(LIBNET_DEP,LIBNET_INCLPATH,LIBNET_LIBPATH)
if test "x$LIBNET_INCLPATH" != "x"
then
@@ -64,14 +66,8 @@
then
LDFLAGS="$LDFLAGS -L$LIBNET_LIBPATH"
fi
-
-dnl Extra defines for libnet
-if test "x$ac_cv_c_bigendian" = "xyes"; then
- AC_DEFINE(LIBNET_BIG_ENDIAN)
-else
- AC_DEFINE(LIBNET_LIL_ENDIAN)
fi
-
+
dnl Determine if -lsocket or -lnsl are needed.
dnl On some platforms (Irix) libnsl and libsocket should not be used.
AC_CHECK_FUNCS(gethostbyname getservbyname)
@@ -111,6 +107,13 @@
FP_C_PROTOTYPES
MG_C_ANSI_CPP
+dnl Extra defines for libnet
+if test "x$ac_cv_c_bigendian" = "xyes"; then
+ AC_DEFINE(LIBNET_BIG_ENDIAN)
+else
+ AC_DEFINE(LIBNET_LIL_ENDIAN)
+fi
+
dnl
dnl library functions
dnl