74b7beec16
changes: General: * Replaced folder icons. New ones by Jakub Steiner. * Don't display playlist numbers elsewhere when turned off. * Support 32-bit and 16-bit "bitfield" bmps in skins. CD Audio: * Supply a dummy user and hostname to the cddb server. * Picked up support for Darwin (from FINK cvs) and NetBSD (from NetBSD cvs) MPG123: * Handle UTF-16 encoded tags. * Major stability fixes Translation/Internationalization: * New translations: Basque (eu), Tajik (tg), Vietnamese (vi), Nynorsk (nn), Thai (th). General: * --play-pause command to toggle playback. * Updated README/man pages. * Added xmms_remote_play_pause(), xmms_remote_playlist_ins_url_string() * Realtime priority works again, it was broken in 1.2.5. * bzip2 skins should now work regardless of Tar version. * Key bindings are now saved when you exit XMMS. * NetWM support updated to the latest specs. * Handles @ in URL's properly if username:password@host is not used. Playlist: * Added 'Sort by date' * Page Up/Down keys scrolls one page, instead of the 3 line inheritance from Winamp. * Extended M3U lists now supported. * Added reading of playlist info for selection. Equalizer: * Added Import/WinAMP Presets to the preset menu to import an entire set of WinAMP presets (WINAMP.q1) into the preset list. Vorbis: * Fixed an endianess problem on smallendian boxes * 1.0rc1 or higher required. MPG123: * Handle more broken mp3s. * No more "-" for mp3s with ID3v2 tags that contain no usable information. * VBR files without XING header are now handled more gracefully. Mikmod: * Mikmod plugin now recognizes mod.* files. CD Audio: * Setting the environmental variable XMMS_CDDB_CLIENT_NAME, will make XMMS use that instead when identifying to CDDB servers. * Better handling of CDDB requests. * Don't poll current time when paused, can cause weird things on some drives. OSS Output: * Do endian/sign conversion if necessary. ESD Output: * Will use ESD stream volume instead of the OSS mixer as default. * Assorted bugfixes/memleaks plugged.
13 lines
476 B
Text
13 lines
476 B
Text
$NetBSD: patch-ak,v 1.5 2002/03/21 18:52:32 drochner Exp $
|
|
|
|
--- wmxmms/Makefile.in.orig Mon Mar 4 22:59:06 2002
|
|
+++ wmxmms/Makefile.in Thu Mar 21 12:59:57 2002
|
|
@@ -190,7 +190,7 @@
|
|
DEFS = @DEFS@ -I. -I$(srcdir) -I.. -I../xmms
|
|
CPPFLAGS = @CPPFLAGS@
|
|
LDFLAGS = @LDFLAGS@
|
|
-LIBS = @LIBS@
|
|
+LIBS = @LIBS@ @PTHREAD_LIBS@ @XML_LIBS@
|
|
wmxmms_OBJECTS = getopt.$(OBJEXT) getopt1.$(OBJEXT) wmxmms.$(OBJEXT)
|
|
wmxmms_DEPENDENCIES = $(top_builddir)/libxmms/libxmms.la
|
|
wmxmms_LDFLAGS =
|