audiocd/cdparanoia patches from Chris Gilbert. Changes: * KRec: Corrected calculation of position in KB. * kio (audiocd): Fix kio-audiocd gives no error message when device permissions are wrong * kio (audiocd): Fix kaudiocreator error "/By Track/Track 01.wav" should start with "audiocd:/" * kmid: Fix KMid doesn't support international characters * juk: Fix Not adding m3u, pls... lists when refreshing directory * juk: Fix Show Total running time of selection/playlist * juk: Fix extra option (random play) in popup-window * juk: Fix TimeLeft widget listens to too many signals * juk: Fix Juk crashed when I was retagging a bunch of songs and started to play with search * Fix FLAC dependency isn't mentioned anywhere and can cause compilation errors * Fix kdemultimedia build fails with parallel make * configure: Fix Extraneous message in admin/Makefile.common using --prefix * kmix: Fix the executable linking against the part, by adding a common library.
138 lines
4.3 KiB
Text
138 lines
4.3 KiB
Text
$NetBSD: patch-aa,v 1.4 2004/04/20 13:13:42 markd Exp $
|
|
|
|
--- configure.orig 2004-04-06 02:48:29.000000000 +1200
|
|
+++ configure
|
|
@@ -34640,7 +34640,7 @@ if test "${ac_cv_lib_FLAC_FLAC__seekable
|
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
else
|
|
ac_check_lib_save_LIBS=$LIBS
|
|
-LIBS="-lFLAC $LIBS"
|
|
+LIBS="-lFLAC -lm $LIBS"
|
|
cat >conftest.$ac_ext <<_ACEOF
|
|
/* confdefs.h. */
|
|
_ACEOF
|
|
@@ -34865,7 +34865,7 @@ echo "${ECHO_T}incs=$para_incdir libs=$p
|
|
echo "${ECHO_T}$with_cdparanoia" >&6
|
|
CDPARANOIA_ROOT="$with_cdparanoia"
|
|
if test "x$CDPARANOIA_ROOT" != "x/usr" ; then
|
|
- CDPARANOIA_INCS="-I${CDPARANOIA_ROOT}/include"
|
|
+ CDPARANOIA_INCS="-I${CDPARANOIA_ROOT}/include/cdparanoia"
|
|
CDPARANOIA_LIBS="-L${CDPARANOIA_ROOT}/lib "
|
|
if test "$USE_RPATH" = "yes" ; then
|
|
CDPARANOIA_RPATH="-R ${CDPARANOIA_ROOT}/lib"
|
|
@@ -35572,7 +35572,7 @@ fi
|
|
echo "$as_me:$LINENO: result: $ac_cv_lib_ossaudio_main" >&5
|
|
echo "${ECHO_T}$ac_cv_lib_ossaudio_main" >&6
|
|
if test $ac_cv_lib_ossaudio_main = yes; then
|
|
- LIBOSSAUDIO="-lossaudio"
|
|
+ LIBOSSAUDIO="${LIBOSSAUDIO}"
|
|
fi
|
|
|
|
|
|
@@ -36995,8 +36995,23 @@ if { (eval echo "$as_me:$LINENO: \"$ac_c
|
|
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
(exit $ac_status); }; }; then
|
|
|
|
- x11_dga2=yes
|
|
-
|
|
+ lib=Xxf86dga
|
|
+ shared_lib_found=no
|
|
+ for i in ${LDFLAGS}; do
|
|
+ case "$i" in
|
|
+ -L*)
|
|
+ dir=`echo $i | sed "s,^-L,,"`
|
|
+ if [ -e $dir/lib${lib}.so ] ||
|
|
+ [ "`echo $dir/lib${lib}.so.*`" != "$dir/lib${lib}.so.*" ]; then
|
|
+ shared_lib_found=yes
|
|
+ break;
|
|
+ fi
|
|
+ esac
|
|
+ done
|
|
+ if [ "$shared_lib_found" = "yes" ]; then
|
|
+ x11_dga2=yes
|
|
+ fi
|
|
+
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
sed 's/^/| /' conftest.$ac_ext >&5
|
|
@@ -37059,7 +37074,22 @@ if { (eval echo "$as_me:$LINENO: \"$ac_c
|
|
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
(exit $ac_status); }; }; then
|
|
|
|
+ lib=Xv
|
|
+ shared_lib_found=no
|
|
+ for i in ${LDFLAGS}; do
|
|
+ case "$i" in
|
|
+ -L*)
|
|
+ dir=`echo $i | sed "s,^-L,,"`
|
|
+ if [ -e $dir/lib${lib}.so ] ||
|
|
+ [ "`echo $dir/lib${lib}.so.*`" != "$dir/lib${lib}.so.*" ]; then
|
|
+ shared_lib_found=yes
|
|
+ break;
|
|
+ fi
|
|
+ esac
|
|
+ done
|
|
+ if [ "$shared_lib_found" = "yes" ]; then
|
|
x11_xv=yes
|
|
+ fi
|
|
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
@@ -37123,7 +37153,22 @@ if { (eval echo "$as_me:$LINENO: \"$ac_c
|
|
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
(exit $ac_status); }; }; then
|
|
|
|
+ lib=Xxf86vm
|
|
+ shared_lib_found=no
|
|
+ for i in ${LDFLAGS}; do
|
|
+ case "$i" in
|
|
+ -L*)
|
|
+ dir=`echo $i | sed "s,^-L,,"`
|
|
+ if [ -e $dir/lib${lib}.so ] ||
|
|
+ [ "`echo $dir/lib${lib}.so.*`" != "$dir/lib${lib}.so.*" ]; then
|
|
+ shared_lib_found=yes
|
|
+ break;
|
|
+ fi
|
|
+ esac
|
|
+ done
|
|
+ if [ "$shared_lib_found" = "yes" ]; then
|
|
x11_xvidmode=yes
|
|
+ fi
|
|
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
@@ -37169,8 +37214,8 @@ cat >>conftest.$ac_ext <<_ACEOF
|
|
#include <sys/types.h>
|
|
typedef int16_t size16;
|
|
typedef int32_t size32;
|
|
- #include <cdda_interface.h>
|
|
- #include <cdda_paranoia.h>
|
|
+ #include <cdparanoia/cdda_interface.h>
|
|
+ #include <cdparanoia/cdda_paranoia.h>
|
|
|
|
int
|
|
main ()
|
|
@@ -37221,7 +37266,7 @@ if test "${ac_cv_lib_cdda_paranoia_paran
|
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
else
|
|
ac_check_lib_save_LIBS=$LIBS
|
|
-LIBS="-lcdda_paranoia -lcdda_paranoia -lcdda_interface $LIBS"
|
|
+LIBS="-lcdda_paranoia -lm -lcdda_interface $LIBS"
|
|
cat >conftest.$ac_ext <<_ACEOF
|
|
/* confdefs.h. */
|
|
_ACEOF
|
|
@@ -37793,10 +37838,10 @@ _ACEOF
|
|
;;
|
|
|
|
NetBSD)
|
|
- echo "$as_me:$LINENO: result: NetBSD :Unknown hardware. You will have problems!!" >&5
|
|
-echo "${ECHO_T}NetBSD :Unknown hardware. You will have problems!!" >&6
|
|
- OS_TYPE="BSD"
|
|
-
|
|
+ echo "$as_me:$LINENO: result: using -lpthread" >&5
|
|
+ echo $ECHO_N "using -lpthread... $ECHO_C" >&6
|
|
+ OS_TYPE="BSD"
|
|
+ LIBPTHREAD="-lpthread"
|
|
cat >>confdefs.h <<\_ACEOF
|
|
#define OS_BSD 1
|
|
_ACEOF
|