1) Remove lang/gnat-aux dependency 2) USE_LANGUAGES+= ada (invokes lang/gcc-aux dependency) 3) USE_TOOLS+= pkg-config (remove hardcoded PATH) 4) Restore use of pkgsrc wrappers 5) Fix bad paths of bin/gate (discovered by updated PKG_DEVELOPER=yes) 6) Use @pkgdir for required empty directory instead of .IGNOREME 7) Add -lgnat for shared libraries, required in this build configuration
13 lines
461 B
Text
13 lines
461 B
Text
$NetBSD: patch-ae,v 1.2 2012/07/08 20:19:00 marino Exp $
|
|
|
|
--- testgtk/Makefile.in.orig 2011-01-19 23:19:14.000000000 +0100
|
|
+++ testgtk/Makefile.in
|
|
@@ -29,7 +29,7 @@
|
|
GTKADA_GL_LIBS=
|
|
endif
|
|
|
|
-GNATMAKELDFLAGS = -largs -L$(src_dir)/lib-obj -L$(opengl_dir) -lgtkada \
|
|
+GNATMAKELDFLAGS = -shared-libgcc -lgnat -L$(src_dir)/lib-obj -L$(opengl_dir) -lgtkada \
|
|
$(GTKADA_GL_LIBS) @GTK_LIBS@ $(TARGET_LFLAGS)
|
|
|
|
all: opengl/view_gl.adb $(OPENGL_C_OBJECTS) $(target)
|