f5a6a01648
- Include standard headers (stdlib.h, string.h, stdio.h) in misc.h to avoid conflicts with built-in declarations of functions. - Change CFLAGS= in Makefile to CFLAGS+= to use pkgsrc-provided CFLAGS. - Include termcap.buildlink3.mk to handle termcap properly. - Add DESTDIR support, use AUTO_MKDIRS. - Bump PKGREVISION. Now I can actually use it! ;)
51 lines
1.1 KiB
Text
51 lines
1.1 KiB
Text
$NetBSD: patch-ad,v 1.2 2008/07/09 05:02:06 bjs Exp $
|
|
|
|
--- spiff.c.orig 1990-02-05 15:17:20.000000000 -0500
|
|
+++ spiff.c
|
|
@@ -27,7 +27,8 @@ static char rcsid[]= "$Header: spiff.c,v
|
|
#include "visual.h"
|
|
#include "output.h"
|
|
|
|
-extern void _Y_doargs();
|
|
+static void _Y_doargs(int argc, char *argv[], char **file1,
|
|
+ char **file2, int *max_d);
|
|
|
|
static int _Y_eflag = 0; /* use exact match algorithm */
|
|
static int _Y_vflag = 0; /* use visual mode */
|
|
@@ -38,9 +39,8 @@ static int _Y_vflag = 0; /* use visual m
|
|
*/
|
|
static int _Y_flags;
|
|
|
|
-main(argc,argv)
|
|
-int argc;
|
|
-char *argv[];
|
|
+int
|
|
+main(int argc, char *argv[])
|
|
{
|
|
E_edit edit_end;
|
|
char *filename[2];
|
|
@@ -120,9 +120,9 @@ char *argv[];
|
|
if (E_NULL != edit_end)
|
|
{
|
|
O_output(edit_end,_Y_flags);
|
|
- return(1);
|
|
+ return 1;
|
|
}
|
|
- return(0);
|
|
+ return 0;
|
|
}
|
|
|
|
/*
|
|
@@ -174,11 +174,7 @@ char *from;
|
|
#define SETPTR {if(strlen(argv[1]) == 2) {argv++;argc--;ptr=argv[1];}else ptr=(&argv[1][2]);}
|
|
|
|
static void
|
|
-_Y_doargs(argc,argv,file1,file2,max_d)
|
|
-int argc;
|
|
-char *argv[];
|
|
-char **file1,**file2;
|
|
-int *max_d;
|
|
+_Y_doargs(int argc, char *argv[], char **file1, char **file2, int *max_d)
|
|
{
|
|
char *ptr;
|
|
|