pkgsrc/databases/postgresql91/patches/patch-src_pl_plperl_GNUmakefile
adam 01563d6958 Changes:
* Fix btree index corruption from insertions concurrent with vacuuming
* Recover from errors occurring during WAL replay of DROP TABLESPACE
* Fix transient zeroing of shared buffers during WAL replay
* Fix postmaster to attempt restart after a hot-standby crash
* Fix corner case in SSI transaction cleanup
* Update per-column permissions, not only per-table permissions, when changing
  table owner
* Fix handling of data-modifying WITH subplans in READ COMMITTED rechecking
* Fix for "could not find plan for CTE" failures
* Fix unsupported node type error caused by COLLATE in an INSERT expression
* Avoid crashing when we have problems deleting table files post-commit
* Fix recently-introduced memory leak in processing of inet/cidr
* Fix GIN cost estimation to handle column IN (...) index conditions
* Fix I/O-conversion-related memory leaks in plpgsql
* Teach pg_upgrade to handle renaming of plpython's shared library (affecting
  upgrades to 9.1)
2012-03-03 14:01:11 +00:00

21 lines
934 B
Text

$NetBSD: patch-src_pl_plperl_GNUmakefile,v 1.3 2012/03/03 14:01:12 adam Exp $
--- src/pl/plperl/GNUmakefile.orig 2012-02-23 22:53:36.000000000 +0000
+++ src/pl/plperl/GNUmakefile
@@ -60,7 +60,6 @@ XSUBPPDIR = $(shell $(PERL) -e 'use List
include $(top_srcdir)/src/Makefile.shlib
-plperl.o: perlchunks.h plperl_opmask.h plperl_helpers.h
plperl_opmask.h: plperl_opmask.pl
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
@@ -70,7 +69,7 @@ perlchunks.h: $(PERLCHUNKS)
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi
$(PERL) $(srcdir)/text2macro.pl --strip='^(\#.*|\s*)$$' $^ > $@
-all: all-lib
+all: perlchunks.h plperl_opmask.h plperl_helpers.h all-lib
SPI.c: SPI.xs plperl_helpers.h
@if [ x"$(perl_privlibexp)" = x"" ]; then echo "configure switch --with-perl was not specified."; exit 1; fi