pkgsrc/lang/py-pygls/patches/patch-setup.py
wiz c02001dee0 lang/py-pygls: import py-pygls-0.9.0
pygls (pronounced like "pie glass") is a pythonic generic implementation
of the Language Server Protocol for use as a foundation for writing
language servers using Python (e.g. Python, XML, etc.). It allows
you to write your own language server in just a few lines of code.
2020-05-18 15:11:01 +00:00

19 lines
382 B
Python

$NetBSD: patch-setup.py,v 1.1 2020/05/18 15:11:01 wiz Exp $
Avoid hardcoding particular module versions.
--- setup.py.orig 2020-04-20 11:29:57.000000000 +0000
+++ setup.py
@@ -48,9 +48,9 @@ docs_require = [
]
tests_require = [
- "mock==3.0.5",
- "pytest==4.5.0",
- "pytest-asyncio==0.10.0"
+ "mock",
+ "pytest",
+ "pytest-asyncio",
]
# pip install pygls