pkgsrc/devel/py-gobject/patches/patch-glib_Makefile.in
adam 4ba4ce8608 py-gobject: updated to 2.28.7
2.28.7:
- Move property and signal creation into _class_init()
- gio-types.defs: change some enums to flags
- Fix set_qdata warning on accessing NULL gobject property
- Disable introspection support by default
- Don't install codegen for Python 3
- Ship tests/te_ST@nouppera in release tarballs for tests to succeed
- [gi] Port test_properties from static gio to GI Gio
- [python3] fix build. PYcairo_IMPORT doesn't exists anymore
- [python3] Fix maketrans import
- [gi-overrides] fix MessageBox so it correctly handles the type constructor param
- gdbus tests: Fix hang if test case fails
- Fix crash in Gtk.TextIter overrides
- correctly initialize the _gi_cairo_functions array to be zero filled
- [gtk-override] print warning if user imports Gtk 2.0
- Add support for enums in gobject.property
2018-01-23 11:23:12 +00:00

15 lines
436 B
Text

$NetBSD: patch-glib_Makefile.in,v 1.1 2018/01/23 11:23:13 adam Exp $
Do not install headers; installed in devel/py-gobject-shared.
--- glib/Makefile.in.orig 2018-01-23 11:11:23.000000000 +0000
+++ glib/Makefile.in
@@ -775,7 +775,7 @@ info: info-am
info-am:
-install-data-am: install-pkgincludeHEADERS install-pyglibLTLIBRARIES \
+install-data-am: install-pyglibLTLIBRARIES \
install-pyglibPYTHON
install-dvi: install-dvi-am