pkgsrc/graphics/dx/patches/patch-ar
drochner fdeab4944f uodate to 4.1.3
changes:
Fixes to several problems that quickly arose with 4.1.2
---------------------------------------------------
- Dependencies of source files on built sources caused build to stop.
It would continue correctly after restarting, but by making the objects
dependent instead we made it work in one pass.
- References in _regstream.c.  Missing references/deletes in _regstream.c
and steamline.c caused objects to be really deleted before their time.
Problem appeared in ThunderStreamlines example.  Did this ever work?
- Not enough memory allocated for buffer in parse.c.
- Needed to pass in class_srcdir value to invokation of class script
in libdx/local.mk
- Include net2c in distribution
- Correctly free search_for in Browser.C.  Proper behavior dependent on
compile-time definitions.
- Not enoucgh memory allocated for type-in string in GARApplication.C.
Caused segfaults in prompter.
2002-02-05 22:23:31 +00:00

12 lines
288 B
Text

$NetBSD: patch-ar,v 1.1 2002/02/05 22:23:33 drochner Exp $
--- src/exec/dxmods/socketconnect.c.orig Tue Feb 5 13:15:07 2002
+++ src/exec/dxmods/socketconnect.c Tue Feb 5 13:15:35 2002
@@ -20,7 +20,6 @@
#else
-#include <pthread.h>
#include <dx/dx.h>
#if defined(HAVE_UNISTD_H)