9afab81d6a
Mozilla Firefox is a free, open-source and cross-platform web browser for Windows, Linux, MacOS X and many other operating systems. It is fast and easy to use, and offers many advantages over other web browsers, such as tabbed browsing and the ability to block pop-up windows. Firefox also offers excellent bookmark and history management, and it can be extended by developers using industry standards such as XML, CSS, JavaScript, C++, etc. Many extensions are available. This package tracks Firefox 45 ESR branch. Changelog from www/firefox 45.0.2: Fixed in Firefox ESR 45.1 2016-47 Write to invalid HashMap entry through JavaScript.watch() 2016-44 Buffer overflow in libstagefright with CENC offsets 2016-39 Miscellaneous memory safety hazards (rv:46.0 / rv:45.1 / rv:38.8)
17 lines
845 B
Text
17 lines
845 B
Text
$NetBSD: patch-ao,v 1.1 2016/04/27 16:36:50 ryoon Exp $
|
|
|
|
--- toolkit/mozapps/installer/packager.mk.orig 2016-04-20 21:33:09.000000000 +0000
|
|
+++ toolkit/mozapps/installer/packager.mk
|
|
@@ -131,9 +131,9 @@ endif
|
|
(cd $(DIST)/$(MOZ_PKG_DIR) && $(TAR) --exclude=precomplete $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(installdir) && tar -xf -)
|
|
$(NSINSTALL) -D $(DESTDIR)$(bindir)
|
|
- $(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
|
|
- ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)
|
|
-ifdef INSTALL_SDK # Here comes the hard part
|
|
+ $(RM) -f $(DESTDIR)$(bindir)/$(MOZILLA_PKG_NAME)
|
|
+ ln -s $(installdir)/$(MOZ_APP_NAME) $(DESTDIR)$(bindir)/${MOZILLA_PKG_NAME}
|
|
+ifeq ($(MOZ_APP_NAME),xulrunner)
|
|
$(NSINSTALL) -D $(DESTDIR)$(includedir)
|
|
(cd $(DIST)/include && $(TAR) $(TAR_CREATE_FLAGS) - .) | \
|
|
(cd $(DESTDIR)$(includedir) && tar -xf -)
|