ef75742c7d
- Fix --with-apr=/usr and/or --with-apr-util=/usr. Problem report 29740. [Max Bowsher <maxb ukf.net>] - mod_proxy: Fix ProxyRemoteMatch directive. Problem report 33170. [Rici Lake <rici ricilake.net>] - mod_proxy: Respect errors reported by pre_connection hooks. [Jeff Trawick] - --with-module can now take more than one module to be statically linked: --with-module=<modtype>:<modfile>,<modtype>:<modfile>,... If the <modtype>-subdirectory doesn't exist it will be created and populated with a standard Makefile.in. [Erik Abele] - Fix the RPM spec file so that an RPM build now works. An RPM build now requires system installations of APR and APR-util. Remove some arbitrary moving around of binaries - the RPM now maps to the ASF build of httpd. [Graham Leggett] - mod_dumpio, an I/O logging/dumping module, added to the modules/expermimental subdirectory. [Jim Jagielski] - mod_auth_ldap: Handle the inconsistent way in which the MS LDAP library handles special characters. Problem report 24437. [Jess Holle] - Win32 MPM: Correct typo in debugging output. [William Rowe] - conf: Remove AddDefaultCharset from the default configuration because setting a site-wide default does more harm than good. Problem report 23421. [Roy Fielding] - Add charset to example CGI scripts. [Roy Fielding] - mod_ssl: fail quickly if SSL connection is aborted rather than making many doomed ap_pass_brigade calls. Problem report 32699. [Joe Orton] - Remove compiled-in upper limit on LimitRequestFieldSize. [Bill Stoddard] - Start keeping track of time-taken-to-process-request again for mod_status if ExtendedStatus is enabled. [Jim Jagielski] - mod_proxy: Handle client-aborted connections correctly. Problem report 32443. [Janne Hietamäki, Joe Orton] - Fix handling of files >2Gb on all platforms (or builds) where apr_off_t is larger than apr_size_t. Problem report 28898. [Joe Orton] - mod_include: Fix bug which could truncate variable expansions of N*64 characters by one byte. Problem report 32985. [Joe Orton] - Correct handling of certain bucket types in ap_save_brigade, fixing possible segfaults in mod_cgi with #include virtual. Problem report 31247. [Joe Orton] - Allow for the use of --with-module=foo:bar where the ./modules/foo directory is local only. Assumes, of course, that the required files are in ./modules/foo, but makes it easier to statically build/log "external" modules. [Jim Jagielski] - Util_ldap: Implemented the util_ldap_cache_getuserdn() API so that ldap authorization only modules have access to the util_ldap user cache without having to require ldap authentication as well. Problem report 31898. [Jari Ahonen jah progress.com, Brad Nicholes] - mod_auth_ldap: Added the directive "Requires ldap-attribute" that allows the module to only authorize a user if the attribute value specified matches the value of the user object. Problem report 31913 [Ryan Morgan <rmorgan pobox.com>] - SECURITY: CAN-2004-0942 (cve.mitre.org) Fix for memory consumption DoS in handling of MIME folded request headers. [Joe Orton] - SECURITY: CAN-2004-0885 (cve.mitre.org) mod_ssl: Fix a bug which allowed an SSLCipherSuite setting to be bypassed during an SSL renegotiation. Problem report 31505. [Hartmut Keil <Hartmut.Keil adnovum.ch>, Joe Orton] - mod_ssl: Fail at startup rather than segfault at runtime if a client cert is configured with an encrypted private key. Problem report 24030. [Joe Orton] - apxs: fix handling of -Wc/-Wl and "-o mod_foo.so". Problem report 31448 [Joe Orton] - mod_ldap: Fix format strings to use %APR_PID_T_FMT instead of %d. [Jeff Trawick] - mod_cache: CacheDisable will only disable the URLs it was meant to disable, not all caching. Problem report 31128. [Edward Rudd <eddie omegaware.com>, Paul Querna] - mod_cache: Try to correctly follow RFC 2616 13.3 on validating stale cache responses. [Justin Erenkrantz] - mod_rewrite: Handle per-location rules when r->filename is unset. Previously this would segfault or simply not match as expected, depending on the platform. [Jeff Trawick] - mod_rewrite: Fix 0 bytes write into random memory position. Problem report 31036. [André Malo] - mod_disk_cache: Do not store aborted content. Problem report 21492. [Rüdiger Plüm <r.pluem t-online.de>] - mod_disk_cache: Correctly store cached content type. Problem report 30278. [Rüdiger Plüm <r.pluem t-online.de>] - mod_ldap: prevent the possiblity of an infinite loop in the LDAP statistics display. Problem report 29216. [Graham Leggett] - mod_ldap: fix a bogus error message to tell the user which file is causing a potential problem with the LDAP shared memory cache. Problem report 31431 [Graham Leggett] - mod_disk_cache: Do not store hop-by-hop headers. [Justin Erenkrantz] - Fix the re-linking issue when purging elements from the LDAP cache Problem report 24801. [Jess Holle <jessh ptc.com>] - mod_disk_cache: Fix races in saving responses. [Justin Erenkrantz] - Fix Expires handling in mod_cache. [Justin Erenkrantz] - Alter mod_expires to run at a different filter priority to allow proper Expires storage by mod_cache. [Justin Erenkrantz]
101 lines
3.6 KiB
Text
101 lines
3.6 KiB
Text
$NetBSD: patch-aa,v 1.14 2005/02/09 14:57:52 tron Exp $
|
|
|
|
--- Makefile.in.orig 2004-11-24 19:31:09.000000000 +0000
|
|
+++ Makefile.in 2005-02-09 13:55:40.000000000 +0000
|
|
@@ -4,7 +4,7 @@
|
|
|
|
PROGRAM_NAME = $(progname)
|
|
PROGRAM_SOURCES = modules.c
|
|
-PROGRAM_LDADD = $(HTTPD_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS) $(LIBS)
|
|
+PROGRAM_LDADD = $(HTTPD_LDFLAGS) $(DL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS) $(LIBS) $(DL_LIBS)
|
|
PROGRAM_DEPENDENCIES = \
|
|
$(BUILTIN_LIBS) \
|
|
$(MPM_LIB) \
|
|
@@ -14,7 +14,7 @@
|
|
PROGRAMS = $(PROGRAM_NAME)
|
|
TARGETS = $(PROGRAMS) $(shared_build) $(other_targets)
|
|
PHONY_TARGETS = $(srcdir)/buildmark.c
|
|
-INSTALL_TARGETS = install-conf install-htdocs install-error install-icons \
|
|
+INSTALL_TARGETS = install-htdocs install-error install-icons \
|
|
install-other install-cgi install-include install-suexec install-man \
|
|
install-build
|
|
|
|
@@ -71,6 +71,7 @@
|
|
< $$i; \
|
|
fi \
|
|
) > $(DESTDIR)$(sysconfdir)/$$i; \
|
|
+ if false; then \
|
|
chmod 0644 $(DESTDIR)$(sysconfdir)/$$i; \
|
|
file=`echo $$i|sed s/-std//`; \
|
|
if [ "$$file" = "httpd.conf" ]; then \
|
|
@@ -79,13 +80,16 @@
|
|
if test "$$file" != "$$i" && test ! -f $(DESTDIR)$(sysconfdir)/$$file; then \
|
|
$(INSTALL_DATA) $(DESTDIR)$(sysconfdir)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
|
|
fi; \
|
|
+ fi; \
|
|
done ; \
|
|
done ; \
|
|
if test -f "$(builddir)/envvars-std"; then \
|
|
cp -p envvars-std $(DESTDIR)$(sbindir); \
|
|
+ if false; then \
|
|
if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
|
|
cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
|
|
fi ; \
|
|
+ fi ; \
|
|
fi
|
|
|
|
install-build:
|
|
@@ -93,8 +97,6 @@
|
|
@test -d $(DESTDIR)$(installbuilddir) || $(MKINSTALLDIRS) $(DESTDIR)$(installbuilddir)
|
|
@cp $(top_srcdir)/build/*.mk $(DESTDIR)$(installbuilddir); \
|
|
cp build/*.mk $(DESTDIR)$(installbuilddir); \
|
|
- sed 's#LIBTOOL = \(.*\)#LIBTOOL = $(SHELL) $(installbuilddir)/libtool $(LTFLAGS)#' \
|
|
- build/config_vars.mk > $(DESTDIR)$(installbuilddir)/config_vars.mk; \
|
|
cp $(top_srcdir)/build/instdso.sh $(DESTDIR)$(installbuilddir); \
|
|
cp $(top_builddir)/config.nice $(DESTDIR)$(installbuilddir);
|
|
|
|
@@ -108,7 +110,7 @@
|
|
doxygen $(top_srcdir)/docs/doxygen.conf
|
|
|
|
install-htdocs:
|
|
- -@if [ -d $(DESTDIR)$(htdocsdir) ]; then \
|
|
+ -@if false; then \
|
|
echo "[PRESERVING EXISTING HTDOCS SUBDIR: $(DESTDIR)$(htdocsdir)]"; \
|
|
else \
|
|
echo Installing HTML documents ; \
|
|
@@ -118,7 +120,7 @@
|
|
fi
|
|
|
|
install-error:
|
|
- -@if [ -d $(DESTDIR)$(errordir) ]; then \
|
|
+ -@if false; then \
|
|
echo "[PRESERVING EXISTING ERROR SUBDIR: $(DESTDIR)$(errordir)]"; \
|
|
else \
|
|
echo Installing error documents ; \
|
|
@@ -128,7 +130,7 @@
|
|
fi
|
|
|
|
install-icons:
|
|
- -@if [ -d $(DESTDIR)$(iconsdir) ]; then \
|
|
+ -@if false; then \
|
|
echo "[PRESERVING EXISTING ICONS SUBDIR: $(DESTDIR)$(iconsdir)]"; \
|
|
else \
|
|
echo Installing icons ; \
|
|
@@ -138,7 +140,7 @@
|
|
fi
|
|
|
|
install-cgi:
|
|
- -@if [ -d $(DESTDIR)$(cgidir) ];then \
|
|
+ -@if false; then \
|
|
echo "[PRESERVING EXISTING CGI SUBDIR: $(DESTDIR)$(cgidir)]"; \
|
|
else \
|
|
echo Installing CGIs ; \
|
|
@@ -191,8 +193,6 @@
|
|
@test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
|
|
@cp -p $(top_srcdir)/docs/man/*.1 $(DESTDIR)$(mandir)/man1
|
|
@cp -p $(top_srcdir)/docs/man/*.8 $(DESTDIR)$(mandir)/man8
|
|
- @(cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir))
|
|
- @(cd $(DESTDIR)$(manualdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null ) || true
|
|
|
|
install-suexec:
|
|
@if test -f $(builddir)/support/suexec; then \
|