pkgsrc/misc/celestia/patches/patch-ak
dholland ebcd261201 Update to 1.6.1. Reset PKGREVISION from 38 (!).
Upstream changes: 5+ years of development; try these links:
   http://www.shatters.net/celestia/161changes.txt
   http://www.shatters.net/celestia/features/160-features.html
   http://www.shatters.net/celestia/151changes.txt
   http://www.shatters.net/celestia/150-feature-summary.html

Restrictions:
   1. The Lua support still does not build, and given that I had to
      patch it to compile at all with Lua disabled it may not work all
      that well this way.
   2. The optional KDE (kde3) build is almost certainly broken; I will
      get to this in a few days if nobody beats me to it.
2013-10-27 21:21:26 +00:00

35 lines
1.3 KiB
Text

$NetBSD: patch-ak,v 1.3 2013/10/27 21:21:26 dholland Exp $
- fix locale directory
- use libintl where needed
--- src/celestia/Makefile.in.orig 2011-06-05 18:34:28.000000000 +0000
+++ src/celestia/Makefile.in
@@ -213,7 +213,7 @@ DCOPIDL = @DCOPIDL@
DCOPIDL2CPP = @DCOPIDL2CPP@
DCOPIDLNG = @DCOPIDLNG@
DCOP_DEPENDENCIES = @DCOP_DEPENDENCIES@
-DEFS = -DCONFIG_DATA_DIR='"$(PKGDATADIR)"' -DLOCALEDIR='"$(datadir)/locale"' @DEFS@
+DEFS = -DCONFIG_DATA_DIR='"$(PKGDATADIR)"' -DLOCALEDIR='"$(localedir)"' @DEFS@
DEPDIR = @DEPDIR@
DL_LIBS = @DL_LIBS@
DSYMUTIL = @DSYMUTIL@
@@ -474,7 +474,7 @@ xdg_menudir = @xdg_menudir@
SUBDIRS = res $(am__append_1) $(am__append_2)
INCLUDES = -I..
@ENABLE_KDE_TRUE@celestiaKDELIBS = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIB_KFILE) \
-@ENABLE_KDE_TRUE@ $(LIBSOCKET) -lDCOP kde/libkdegui.a
+@ENABLE_KDE_TRUE@ $(LIBSOCKET) $(LIBINTL) -lDCOP kde/libkdegui.a
@ENABLE_KDE_TRUE@celestia_LDFLAGS = $(all_libraries) $(KDE_RPATH)
@ENABLE_GTK_TRUE@celestiaGTKLIBS = $(GTK_LIBS) gtk/libgtkgui.a
@@ -538,7 +538,8 @@ celestia_LDADD = \
../cel3ds/libcel3ds.a \
../celmath/libcelmath.a \
../celutil/libcelutil.a \
- $(SPICE_LIBS)
+ $(SPICE_LIBS) \
+ $(INTLLIBS)
noinst_HEADERS = $(wildcard *.h)
noinst_DATA = ../../celestia