* docs: help screen & man page * docs: add missing full-html flag * headers: include-what-you-use fixes * other: free backup ranges * prepare_memory bug: initialization missing * licensing: use FreeBSD license (was GNUv3) * parse_leases: exit at read error * getdata: realloc instead of asserting * getdata: potential overflow due unit change * bug: use uint32_t for IP numbers * analyze: use more logical variable names * getdata: initialize memory * all: include-what-you-see fixes * analyze: debugging leftover removed * THANKS: add Ahmed AL Dakhil * maint: coding style fixes * output: change to full html behaviour * build-sys: autotools configure.ac update * docs: NEWS update * docs: remove version from manual page * licensing: set placeholder properly * bug: use uint32_t for IP numbers * build-sys: ignore gprof & gcov files * getdata: new xstrstr function for performance * other: fix two warnings * build-sys: update news for release v2.16
26 lines
632 B
C
26 lines
632 B
C
$NetBSD: patch-src_getdata.c,v 1.1 2011/07/20 07:03:53 adam Exp $
|
|
|
|
Don't include features.h; move string.h to dhcpd-pools.h.
|
|
|
|
--- src/getdata.c.orig 2011-07-20 06:30:23.000000000 +0000
|
|
+++ src/getdata.c
|
|
@@ -43,19 +43,12 @@ extern char *malloc();
|
|
#define EXIT_SUCCESS 0 /* Successful exit status. */
|
|
#endif /* STDC_HEADERS */
|
|
|
|
-#ifdef HAVE_STRING_H
|
|
-#include <string.h>
|
|
-#else
|
|
-#include <strings.h>
|
|
-#endif
|
|
-
|
|
#include <arpa/inet.h>
|
|
#include <assert.h>
|
|
#include <ctype.h>
|
|
#include <err.h>
|
|
#include <errno.h>
|
|
#include <fcntl.h>
|
|
-#include <features.h>
|
|
#include <netinet/in.h>
|
|
#include <stddef.h>
|
|
#include <stdint.h>
|