pkgsrc/net/avahi/patches/patch-aa
rodent d1079112d5 Support more PKG_OPTIONS for the net/avahi package. This enables the user
to build the avahi UI with GTK3, which is required for some packages like
libepc. Commented patches. Removed dependency on desktop.mk, as the file
doesn't have a MimeType key. Only PKG_OPTION enabled by default is gtk2.
Thus, you will notice no difference in this version and the last (unless
you start enabling options). Bump PKGREVISION. Resolves PR pkg/47483
2013-04-21 00:58:46 +00:00

20 lines
461 B
Text

$NetBSD: patch-aa,v 1.3 2013/04/21 00:58:47 rodent Exp $
Add NetBSD support.
--- avahi-core/iface-pfroute.c.orig 2010-06-26 00:14:35.000000000 +0000
+++ avahi-core/iface-pfroute.c
@@ -46,6 +46,13 @@
#include "iface-pfroute.h"
#include "util.h"
+#ifdef __NetBSD__
+#define lifreq if_laddrreq
+#define lifr_addr iflr_addr
+#define lifr_flags iflr_flags
+#define SIOCGLIFFLAGS SIOCGIFFLAGS
+#endif
+
static int bitcount (unsigned int n)
{
int count=0 ;