2ae41a07ef
- IPv6 patch will be maintained at ftp://ftp.piuha.net/pub/misc/ A better ChangeLog (1.3.19 -> 1.3.20) is available in pkgsrc/www/apache/Makefile rev 1.73
21 lines
668 B
Text
21 lines
668 B
Text
$NetBSD: patch-af,v 1.4 2001/10/08 13:23:37 martti Exp $
|
|
|
|
--- src/modules/standard/mod_so.c.orig Tue Feb 27 04:59:53 2001
|
|
+++ src/modules/standard/mod_so.c Mon Oct 8 14:34:14 2001
|
|
@@ -308,7 +308,15 @@
|
|
return err;
|
|
}
|
|
|
|
- file = ap_server_root_relative(cmd->pool, filename);
|
|
+ /*
|
|
+ * If the filename starts with '!', then just dlopen() it without
|
|
+ * translating it to a pathname relative to ServerRoot.
|
|
+ */
|
|
+ if (filename[0] == '!') {
|
|
+ file = filename + 1;
|
|
+ } else {
|
|
+ file = ap_server_root_relative(cmd->pool, filename);
|
|
+ }
|
|
|
|
if (!(handle = ap_os_dso_load(file))) {
|
|
const char *my_error = ap_os_dso_error();
|