pkgsrc/multimedia/mkvtoolnix/patches/patch-ad
wiz 434aa7f455 Support flac-1.1.3 based on a patch from
ftp.altlinux.org /pub/people/thresh
Bump PKGREVISION because this package just compiled without flac support.
2007-01-13 21:58:24 +00:00

24 lines
921 B
Text

$NetBSD: patch-ad,v 1.1 2007/01/13 21:58:24 wiz Exp $
--- configure.in.orig 2006-04-28 14:52:55.000000000 +0000
+++ configure.in
@@ -495,8 +495,8 @@ dnl
[ with_flac=${withval} ], [ with_flac=yes ])
if test "$with_flac" != "no"; then
- AC_CHECK_LIB(FLAC, FLAC__seekable_stream_decoder_new,
- [ FLAC_LIBS="-lFLAC -lm"
+ AC_CHECK_LIB(FLAC, FLAC__stream_decoder_new,
+ [ FLAC_LIBS="-lFLAC $OGG_LIBS -lm"
flac_found=yes ],
[ flac_found=no ],
"-lm")
@@ -510,7 +510,7 @@ dnl
])
fi
if test x"$flac_found" = xyes ; then
- AC_CHECK_LIB(FLAC, FLAC__seekable_stream_decoder_skip_single_frame,
+ AC_CHECK_LIB(FLAC, FLAC__stream_decoder_skip_single_frame,
[ flac_decoder_skip_found=yes ],
[ flac_decoder_skip_found=no ],
$FLAC_LIBS)